POJ-1466-Girls and Boys(二分图最大独立集)

Girls and Boys

Description

In the second year of the university somebody started a study on the romantic relations between the students. The relation "romantically involved" is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been "romantically involved". The result of the program is the number of students in such a set.

Input

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description: 

the number of students 
the description of each student, in the following format 
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ... 
or 
student_identifier:(0) 

The student_identifier is an integer number between 0 and n-1 (n <=500 ), for n subjects.

Output

For each given data set, the program should write to standard output a line containing the result.

Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Sample Output

5
2


题目大意:有n个人每个人又和别的人有关系,求的是没有关系的最大人数。

输入:

第一行  n个人,接下来n行 0--n-1:(与此人有关系的人的个数 )  有关系的人。

求的是二分图的最大独立集,此题不用划分集合,所以最后的最大匹配数要除以2。

二分图最大独立集 = N - 最大匹配数。



#include <stdio.h>
#include <iostream>
#include <stdlib.h>
#include <string.h>
using namespace std;

int map[1000][1000],vist[1000],link[1000];
int cas,k,num;

int dfs (int x)
{
    for (int i = 0; i < cas; i++)
    {
        if ( map[x][i] && vist[i] == 0)
        {
            vist[i] = 1;
            if ( link [i] == -1 || dfs(link[i]) )
            {
                link[i] = x;
                return 1;
            }
        }
    }
    return 0;
}

int main ()
{
    while (~scanf ("%d",&cas)&&cas)
    {
        memset (map,0,sizeof (map));
        memset (link,-1,sizeof (link));
        for (int i = 0; i < cas; i++)
        {
            scanf ("%d : (%d)",&k,&num);
            for (int j = 0; j < num; j++)
            {
                int x;
                scanf ("%d",&x);
                map[k][x] = 1;
            }
        }
        int sum = 0;
        for (int i = 0 ; i < cas; i++)
        {
            memset(vist,0,sizeof (vist));
            if (dfs (i) )
                sum ++;
        }

        sum /=2;
        printf ("%d\n",cas - sum);
    }
    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值