HDUOJ_5137(dijkstra)(How Many Maos Does the Guanxi Worth)

HDUOJ_5137(dijkstra)(How Many Maos Does the Guanxi Worth)

How Many Maos Does the Guanxi Worth

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 1029    Accepted Submission(s): 351
Problem Description
"Guanxi" is a very important word in Chinese. It kind of means "relationship" or "contact". Guanxi can be based on friendship, but also can be built on money. So Chinese often say "I don't have one mao (0.1 RMB) guanxi with you." or "The guanxi between them is naked money guanxi." It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things.
Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance, someone may make their children enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu's guanxi net consists of N people including Boss Liu and the schoolmaster. In this net, two persons who has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A "big money" means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net -- it means that if there is a guanxi between A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help ...... If the request finally reaches the schoolmaster, Boss Liu's kid will be accepted by the middle school. Of course, all helpers including the schoolmaster are paid by Boss Liu.

You hate Boss Liu and you want to undermine Boss Liu's plan. All you can do is to persuade ONE person in Boss Liu's guanxi net to reject any request. This person can be any one, but can't be Boss Liu or the schoolmaster. If you can't make Boss Liu fail, you want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely succeed.
 Input
There are several test cases.
For each test case:
The first line contains two integers N and M. N means that there are N people in Boss Liu's guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N. M means that there are M guanxis in Boss Liu's guanxi net. (3 <=N <= 30, 3 <= M <= 1000)

Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.

The input ends with N = 0 and M = 0.

It's guaranteed that Boss Liu's request can reach the schoolmaster if you do not try to undermine his plan.
 Output
For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print "Inf" instead.
 Sample Input
  
  
4 5 1 2 3 1 3 7 1 4 50 2 3 4 3 4 2 3 2 1 2 30 2 3 10 0 0
 Sample Output
  
  
50 Inf
 Source

 
题目大意:有N个人(点),1代表刘老板,N代表校长,1要找N办事,但1不认识N,但是1可以通过关系网找N办事,在1和N之间的关系网中总共有N个人(包括1和N)。A和B认识,如果A找B办事,A要付钱给B,同样B找A办事,也要付相同的钱给A。如果A要找C办事,但是A和C不认识,A和B认识,B和C认识,这样A可以找B办事,B再找C办事,这样A就可以间接让C办事。最后所有的花费都由1(刘老板)支付。题目给出的数据都能保证1能找到N办事。你要做的是说服且 只能说服这N个人中的一个人h不帮任何人办事(这个人不能是1和N),尽可能 使1不能成功找到N帮忙如果避免不了,1肯定会从剩下的人中找一条花费最少的路径找N办事。此时你需要说服某个人h,从而使1的花费尽可能大。最终若1不能找到N帮忙,输出Inf,否则输出1(刘老板)最终要付多少钱。


思路:刚开始一看到这题,错误理解为求最小生成树,用prim。最后发现理解错了。1可能通过 t(t<=N-2)个人找到N办事,不是全连通,而是求最短路径,只不过在找路径的时候,不能访问某个点h(被说服的那个人),在处理数据时把该点标记一下,就解决了。(起初想到把所有与h相连的点的边权值设为无穷大,但是由于要通过比较,找到一条使1花费最大的路径,所以h不固定,因此不能设为无穷大,否则会造成数据丢失)。


My   solution:

/*2015.8.22*/

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define  INF  0x3f3f3f3f
int map[33][33],d[33],n;


void dijkstra()
{
	int h,v,i,mark[33],ex=0;
	for(h=2;h<n;h++)/*使h遍历除1和N点外所有的点,找到使N花费最大的h点(剔除该h点,使得1花费最大)*/ 
	{ 
		memset(d,0x3f,sizeof(d));/*每更新一次h点,d数组和mark数组都要重新初始化*/
		memset(mark,0,sizeof(mark));
		d[1]=0;
		mark[h]=1;/*标记h点,不访问该点*/
		while(true)
		{
			v=-1;
			for(i=1;i<=n;i++)
			if(!mark[i]&&(v==-1||d[i]<d[v]))
			v=i;
			if(v==-1)
			break;
			mark[v]=1;
			for(i=1;i<=n;i++)
			d[i]=min(d[i],d[v]+map[v][i]);
		}
		if(d[n]==INF)
		{
			printf("Inf\n");/*一但1到N的距离为无穷大(d[n]=INF),此时h点就是要找的点,输出Inf并结束函数调用*/ 
			return ;
		}
		else
		if(ex<d[n])/*更新1(刘老板)要付的费用。注意:这里是小于号,使1的花费尽可能大。*/
		ex=d[n];
	}
	printf("%d\n",ex);	
}
int main()
{
	int  m,i,j,a,b,c;
	while(scanf("%d%d",&n,&m)==2&&(n||m))
	{
		memset(map,0x3f,sizeof(map));
		for(i=0;i<m;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			if(map[a][b]>c)/*防止重边,若有较小值,则更新为较小值*/
			{
				map[a][b]=c;/*无向图,所以要双向赋值*/
				map[b][a]=c;
			}
		}
		dijkstra();
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值