Wilbur and Swimming Pool(矩形求面积)

19 篇文章 0 订阅
15 篇文章 0 订阅


Wilbur and Swimming Pool
Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:262144KB     64bit IO Format:%I64d & %I64u

Description

After making bad dives into swimming pools, Wilbur wants to build a swimming pool in the shape of a rectangle in his backyard. He has set up coordinate axes, and he wants the sides of the rectangle to be parallel to them. Of course, the area of the rectangle must be positive. Wilbur had all four vertices of the planned pool written on a paper, until his friend came along and erased some of the vertices.

Now Wilbur is wondering, if the remaining n vertices of the initial rectangle give enough information to restore the area of the planned swimming pool.

Input

The first line of the input contains a single integer n (1 ≤ n ≤ 4) — the number of vertices that were not erased by Wilbur's friend.

Each of the following n lines contains two integers xi and yi ( - 1000 ≤ xi, yi ≤ 1000) —the coordinates of the i-th vertex that remains. Vertices are given in an arbitrary order.

It's guaranteed that these points are distinct vertices of some rectangle, that has positive area and which sides are parallel to the coordinate axes.

Output

Print the area of the initial rectangle if it could be uniquely determined by the points remaining. Otherwise, print  - 1.

Sample Input

Input
2
0 0
1 1
Output
1
Input
1
1 1
Output
-1

Sample Output

     
     
302000
 

Hint

In the first sample, two opposite corners of the initial rectangle are given, and that gives enough information to say that the rectangle is actually a unit square.

In the second sample there is only one vertex left and this is definitely not enough to uniquely define the area.

题意:矩形的边和坐标轴平行,原本矩形4个顶点已知,后来由于某种原因擦除后,还剩下n(1<=n<=4)个矩形的顶点,根据这n个顶点判断能不能唯一确定一个矩形,若能则输出矩形面积,反之输出-1.

思路:把这n个矩形的纵坐标、横坐标分别排序。无论是一个点还是2、3、4点,在经过排序后,若排在最后一个横坐标与排在最前的一个横坐标相等,说明这n个点在一条竖直线上,同样若排在最后一个纵坐标与排在最前的一个纵坐标相等,说明这n个点在一条横直线上,这些点都不能确定一个矩形。最后一个纵坐标与排在最前的一个纵坐标不相等

且最后一个横坐标与排在最前的一个横坐标不相等,说明至少有两个点在矩形对角线上,这样就可以唯一确定矩形。

h=x[n-1]-x[0];//矩形的宽

s=y[n-1]-y[0]//矩形的长

area=h*s;

My   solution:

/*2016.3.12*/

#include<stdio.h>
#include<algorithm>
using namespace std;
int x[5],y[5];
int main()
{
	int i,j,k,n,m;
	while(scanf("%d",&n)==1)
	{
		for(i=0;i<n;i++)
		scanf("%d%d",&x[i],&y[i]);
		sort(x,x+n);
		sort(y,y+n);
		if(x[0]!=x[n-1]&&y[0]!=y[n-1])
		{
			m=(x[n-1]-x[0])*(y[n-1]-y[0]);
			printf("%d\n",m);
		}
		else
		printf("-1\n");
	}
	return  0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值