Compromise
-
Time Limit:
- 1000ms Memory limit:
- 65536kB
-
题目描述
-
In a few months the European Currency Union will become a reality. However, to join the club, the Maastricht criteria must be fulfilled, and this is not a trivial task for the countries (maybe except for Luxembourg). To enforce that Germany will fulfill the criteria, our government has so many wonderful options (raise taxes, sell stocks, revalue the gold reserves,...) that it is really hard to choose what to do.
Therefore the German government requires a program for the following task:
Two politicians each enter their proposal of what to do. The computer then outputs the longest common subsequence of words that occurs in both proposals. As you can see, this is a totally fair compromise (after all, a common sequence of words is something what both people have in mind).
Your country needs this program, so your job is to write it for us.
输入
-
The input will contain several test cases.
Each test case consists of two texts. Each text is given as a sequence of lower-case words, separated by whitespace, but with no punctuation. Words will be less than 30 characters long. Both texts will contain less than 100 words and will be terminated by a line containing a single '#'.
Input is terminated by end of file.
输出
- For each test case, print the longest common subsequence of words occuring in the two texts. If there is more than one such sequence, any one is acceptable. Separate the words by one blank. After the last word, output a newline character. 样例输入
-
die einkommen der landwirte sind fuer die abgeordneten ein buch mit sieben siegeln um dem abzuhelfen muessen dringend alle subventionsgesetze verbessert werden # die steuern auf vermoegen und einkommen sollten nach meinung der abgeordneten nachdruecklich erhoben werden dazu muessen die kontrollbefugnisse der finanzbehoerden dringend verbessert werden #
样例输出
-
die einkommen der abgeordneten muessen dringend verbessert werden
Global No.
- 1252
用1来标记【I][J]说明第一个子串和第二个子串的第I个和第J和是相同,接着直接递归到[I-1][J-1],最后输出相同的那个
接着对于另外的两种,分别标记为1,2即可,标号比较简单
#include<stdio.h>
#include<string.h>
char x[101][31],y[101][31];
int ans[101][101],m,n,l[101][101];
bool flag;
void print(int i=m-1,int j=n-1)
{
if(i==-1||j==-1) return;
if(l[i][j]==1)
{
print(i-1,j-1);
if(flag) printf(" ");
else flag=true;
printf("%s",x[i]);
}
if(l[i][j]==2) print(i-1,j);
if(l[i][j]==3) print(i,j-1);
}
int main()
{
m=n=0;
while(scanf("%s",x[m])!=EOF)
{
while(scanf("%s",x[++m]),x[m][0]!='#');
while(scanf("%s",y[n]),y[n][0]!='#')++n;
for(int i=0;i<=m;i++) ans[i][0]=0;
for(int i=0;i<=n;i++) ans[0][i]=0;
for(int i=0;i<m;i++)
for(int j=0;j<n;j++)
if(strcmp(x[i],y[j])==0)
{
ans[i+1][j+1]=ans[i][j]+1;
l[i][j]=1;
}
else
if(ans[i+1][j]<=ans[i][j+1])
{
ans[i+1][j+1]=ans[i][j+1];
l[i][j]=2;
}
else
{
ans[i+1][j+1]=ans[i+1][j];
l[i][j]=3;
}
flag=false;
print();
printf("/n");
m=n=0;
}
return 0;
}