POJ 1256 Anagram

Anagram
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12070 Accepted: 4933

Description

You are to write a program that has to generate all possible words from a given set of letters.
Example: Given the word "abc", your program should - by exploring all different combination of the three letters - output the words "abc", "acb", "bac", "bca", "cab" and "cba".
In the word taken from the input file, some letters may appear more than once. For a given word, your program should not produce the same word more than once, and the words should be output in alphabetically ascending order.

Input

The input consists of several words. The first line contains a number giving the number of words to follow. Each following line contains one word. A word consists of uppercase or lowercase letters from A to Z. Uppercase and lowercase letters are to be considered different. The length of each word is less than 13.

Output

For each word in the input, the output should contain all different words that can be generated with the letters of the given word. The words generated from the same input word should be output in alphabetically ascending order. An upper case letter goes before the corresponding lower case letter.

Sample Input

3
aAb
abc
acba

Sample Output

Aab
Aba
aAb
abA
bAa
baA
abc
acb
bac
bca
cab
cba
aabc
aacb
abac
abca
acab
acba
baac
baca
bcaa
caab
caba
cbaa

Hint

An upper case letter goes before the corresponding lower case letter.
So the right order of letters is 'A'<'a'<'B'<'b'<...<'Z'<'z'.

Source

 

 

回溯法

 

#include<stdio.h>

#include<algorithm>

#include<cctype>

using namespace std;

char s[20];

char res[20];

bool b[20];

int N;

int cmp(char a,char b)

{

    if(islower(a)&&islower(b))   return a<b;

    if(isupper(a)&&isupper(b))   return a<b;

    if(islower(a)&&isupper(b))   return a<(b-'A'+'a');

    if(isupper(a)&&islower(b))   return a<=(b-'a'+'A');

}

void backtrace(int n)

{

    if(n==N)

    {

        printf("%s/n",res);

        return ;

    }

    int i;

    for(i=0; i<N; ++i)

    {

        if(b[i]==false)

        {

            res[n]=s[i];

            b[i]=true;

            backtrace(n+1);

            b[i]=false;

            while(i<(N-1) && s[i]==s[i+1])//跳过相同的字符

                i++;

        }

    }

}

int main()

{

    int T;

    while(scanf("%d",&T)!=EOF)

    {

        while(T--)

        {

            scanf("%s",&s);

            N=strlen(s);

            res[N]='/0';

            sort(s,s+N,cmp);

            memset(b,0,sizeof(b));

            backtrace(0);

        }

    }

    return 0;

}

STL:
#include<cstdio>
#include<cstring>
#include<cctype>
#include<algorithm>
using namespace std;
char str[20];
bool cmp(char a,char b)
{
    /*if(islower(a)&&islower(b))   return a<b;
    if(isupper(a)&&isupper(b))   return a<b;
    if(islower(a)&&isupper(b))   return a<(b-'A'+'a');
    if(isupper(a)&&islower(b))   return a<=(b-'a'+'A');*/
    if(tolower(a)==tolower(b))  return a<b;
    return tolower(a)<tolower(b);
}
int main()
{
    int T;
    while(scanf("%d",&T)!=EOF)
    {
        while(T--)
        {
            scanf("%s",str);
            int n=strlen(str);
            sort(str,str+n,cmp);
            printf("%s/n",str);
            while(next_permutation(str,str+n,cmp))//别忘了加CMP
            printf("%s/n",str);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值