Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 4523 | Accepted: 2648 |
Description
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.
Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.
1733
3733
3739
3779
8779
8179
Input
Output
Sample Input
3 1033 8179 1373 8017 1033 1033
Sample Output
6 7 0
Source
#include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;
bool prime[10000]= {false};
bool vis[10000];
void init()
{
prime[0]=prime[1]=true;
for(int i=2; i*i<10000; i++)
{
if(!prime[i])
{
for(int j=i*i; j<10000; j+=i)
prime[j]=true;
}
}
}
queue<int> q;
int main()
{
int T,x,y;
scanf("%d",&T);
init();
while(T--)
{
memset(vis,false,sizeof(vis));
scanf("%d%d",&x,&y);
if(x==y)
{
printf("0/n");
continue;
}
q.push(x);
vis[x]=true;
bool flag=false;
int num=0;
int head=0,end=0,cnt=1;
while(!q.empty()&&!flag)
{
head=end;
end=cnt;
num++;
while(head<end&&!flag)
{
int t=q.front();
q.pop();
int tt=t;
int a,b,c,d;
d=t/1000;
t=t%1000;
c=t/100;
t=t%100;
b=t/10;
t=t%10;
a=t;
t=tt;
head++;
for(int i=1; i<=9; i++)
if(i!=d)
{
tt=t;
tt=tt-1000*d;
tt=tt+1000*i;
if(tt==y)
{
flag=true;
break;
}
if(vis[tt]==false&&prime[tt]==false)
{
q.push(tt);
vis[tt]=true;
cnt++;
}
}
for(int i=0; i<=9&&!flag; i++)
if(i!=c)
{
tt=t;
tt=tt-100*c;
tt=tt+100*i;
if(tt==y)
{
flag=true;
break;
}
if(vis[tt]==false&&prime[tt]==false)
{
q.push(tt);
vis[tt]=true;
cnt++;
}
}
for(int i=0; i<=9&&!flag; i++)
if(i!=b)
{
tt=t;
tt=tt-10*b;
tt=tt+10*i;
if(tt==y)
{
flag=true;
break;
}
if(vis[tt]==false&&prime[tt]==false)
{
q.push(tt);
vis[tt]=true;
cnt++;
}
}
for(int i=0; i<=9&&!flag; i++)
if(i!=a)
{
tt=t;
tt=tt-a;
tt=tt+i;
if(tt==y)
{
flag=true;
break;
}
if(vis[tt]==false&&prime[tt]==false)
{
q.push(tt);
vis[tt]=true;
cnt++;
}
}
}
}
while(!q.empty()) q.pop();
if(flag) printf("%d/n",num);
else printf("Impossible/n");
}
return 0;
}