Stealing Harry Potter's Precious
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 234 Accepted Submission(s): 121
Problem Description
Harry Potter has some precious. For example, his invisible robe, his wand and his owl. When Hogwarts school is in holiday, Harry Potter has to go back to uncle Vernon's home. But he can't bring his precious with him. As you know, uncle Vernon never allows such magic things in his house. So Harry has to deposit his precious in the Gringotts Wizarding Bank which is owned by some goblins. The bank can be considered as a N × M grid consisting of N × M rooms. Each room has a coordinate. The coordinates of the upper-left room is (1,1) , the down-right room is (N,M) and the room below the upper-left room is (2,1)..... A 3×4 bank grid is shown below:
Some rooms are indestructible and some rooms are vulnerable. Goblins always care more about their own safety than their customers' properties, so they live in the indestructible rooms and put customers' properties in vulnerable rooms. Harry Potter's precious are also put in some vulnerable rooms. Dudely wants to steal Harry's things this holiday. He gets the most advanced drilling machine from his father, uncle Vernon, and drills into the bank. But he can only pass though the vulnerable rooms. He can't access the indestructible rooms. He starts from a certain vulnerable room, and then moves in four directions: north, east, south and west. Dudely knows where Harry's precious are. He wants to collect all Harry's precious by as less steps as possible. Moving from one room to another adjacent room is called a 'step'. Dudely doesn't want to get out of the bank before he collects all Harry's things. Dudely is stupid.He pay you $1,000,000 to figure out at least how many steps he must take to get all Harry's precious.
Some rooms are indestructible and some rooms are vulnerable. Goblins always care more about their own safety than their customers' properties, so they live in the indestructible rooms and put customers' properties in vulnerable rooms. Harry Potter's precious are also put in some vulnerable rooms. Dudely wants to steal Harry's things this holiday. He gets the most advanced drilling machine from his father, uncle Vernon, and drills into the bank. But he can only pass though the vulnerable rooms. He can't access the indestructible rooms. He starts from a certain vulnerable room, and then moves in four directions: north, east, south and west. Dudely knows where Harry's precious are. He wants to collect all Harry's precious by as less steps as possible. Moving from one room to another adjacent room is called a 'step'. Dudely doesn't want to get out of the bank before he collects all Harry's things. Dudely is stupid.He pay you $1,000,000 to figure out at least how many steps he must take to get all Harry's precious.
Input
There are several test cases.
In each test cases:
The first line are two integers N and M, meaning that the bank is a N × M grid(0<N,M <= 100).
Then a N×M matrix follows. Each element is a letter standing for a room. '#' means a indestructible room, '.' means a vulnerable room, and the only '@' means the vulnerable room from which Dudely starts to move.
The next line is an integer K ( 0 < K <= 4), indicating there are K Harry Potter's precious in the bank.
In next K lines, each line describes the position of a Harry Potter's precious by two integers X and Y, meaning that there is a precious in room (X,Y).
The input ends with N = 0 and M = 0
In each test cases:
The first line are two integers N and M, meaning that the bank is a N × M grid(0<N,M <= 100).
Then a N×M matrix follows. Each element is a letter standing for a room. '#' means a indestructible room, '.' means a vulnerable room, and the only '@' means the vulnerable room from which Dudely starts to move.
The next line is an integer K ( 0 < K <= 4), indicating there are K Harry Potter's precious in the bank.
In next K lines, each line describes the position of a Harry Potter's precious by two integers X and Y, meaning that there is a precious in room (X,Y).
The input ends with N = 0 and M = 0
Output
For each test case, print the minimum number of steps Dudely must take. If Dudely can't get all Harry's things, print -1.
Sample Input
2 3 ##@ #.# 1 2 2 4 4 #@## .... #### .... 2 2 1 2 4 0 0
Sample Output
-1 5
Source
2013 Asia Hangzhou Regional Contest
解题思路:当时在场外看现场赛的题目的时候就想自己去了这个赛区就好了有木有啊!!!这题我做过啊!!!杭电上的原题啊!!!还是2005杭州的原题啊!!!
请移步http://acm.hdu.edu.cn/showproblem.php?pid=1044
两题思路几乎一模一样,1044可能还难一点,主要就是先bfs处理出任意两点间的最短距离,再在新建的图上做dfs枚举下路线就行了
解题思路:当时在场外看现场赛的题目的时候就想自己去了这个赛区就好了有木有啊!!!这题我做过啊!!!杭电上的原题啊!!!还是2005杭州的原题啊!!!
请移步http://acm.hdu.edu.cn/showproblem.php?pid=1044
两题思路几乎一模一样,1044可能还难一点,主要就是先bfs处理出任意两点间的最短距离,再在新建的图上做dfs枚举下路线就行了
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define N 105
#define Inf 0x7fffffff
using namespace std;
char map[N][N];
int mov[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
int dis[N][N],head[N],t,ans;
bool vis[5];
struct Node
{
int x;
int y;
int step;
};
struct
{
int e;
int w;
int next;
}edge[N];
void add(int s,int e,int w)
{
edge[t].e=e;
edge[t].w=w;
edge[t].next=head[s];
head[s]=t++;
}
void bfs(int x,int y,int m,int n)
{
int i,j,xi,yi;
bool visit[N][N];
for(i=1;i<=m;i++)
for(j=1;j<=n;j++)
dis[i][j]=Inf;
memset(visit,false,sizeof(visit));
dis[x][y]=0;
visit[x][y]=true;
queue<Node> q;
Node ini;
ini.x=x;ini.y=y;ini.step=0;
q.push(ini);
while(!q.empty())
{
ini=q.front();
q.pop();
for(i=0;i<4;i++)
{
xi=ini.x+mov[i][0];yi=ini.y+mov[i][1];
if(!visit[xi][yi]&&map[xi][yi]!='#')
{
visit[xi][yi]=true;
dis[xi][yi]=ini.step+1;
Node tmp;
tmp.x=xi;tmp.y=yi;
tmp.step=ini.step+1;
q.push(tmp);
}
}
}
}
void dfs(int pos,int now,int cnt,int num)
{
int i;
if(cnt==num)
{
ans=min(ans,now);
return ;
}
for(i=head[pos];i!=-1;i=edge[i].next)
{
int ed=edge[i].e;
if(!vis[ed])
{
vis[ed]=true;
dfs(ed,now+edge[i].w,cnt+1,num);
vis[ed]=false;
}
}
return ;
}
int main()
{
int m,n,i,j,k,x[4],y[4],x0,y0;
bool flag;
while(~scanf("%d%d",&m,&n),m+n)
{
ans=Inf;
flag=true;
getchar();
memset(map,'#',sizeof(map));
memset(head,-1,sizeof(head));
memset(vis,false,sizeof(vis));
t=0;
for(i=1;i<=m;i++)
{
for(j=1;j<=n;j++)
{
scanf("%c",&map[i][j]);
if(map[i][j]=='@')
x0=i,y0=j;
}
getchar();
}
scanf("%d",&k);
for(i=0;i<k;i++)
scanf("%d%d",&x[i],&y[i]);
bfs(x0,y0,m,n);//bfs求出发点到各点的最短距离
for(i=0;i<k;i++)
if(dis[x[i]][y[i]]==Inf)//有不可达点直接输出-1
{
flag=false;
break;
}
if(!flag)
{
printf("-1\n");
continue;
}
for(i=0;i<k;i++)
add(k,i,dis[x[i]][y[i]]);//重新建图
for(i=0;i<k;i++)
//对任意两个宝藏点以及宝藏点与出发点连边建图
{
bfs(x[i],y[i],m,n);
for(j=0;j<k;j++)
add(i,j,dis[x[j]][y[j]]);
add(i,k,dis[x0][y0]);
}
vis[k]=true;
dfs(k,0,0,k);//在新建的图上做dfs即可
printf("%d\n",ans);
}
return 0;
}