HDU 3666 THE MATRIX PROBLEM 差分约束

THE MATRIX PROBLEM

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6845    Accepted Submission(s): 1763


Problem Description
You have been given a matrix C N*M, each element E of C N*M is positive and no more than 1000, The problem is that if there exist N numbers a1, a2, … an and M numbers b1, b2, …, bm, which satisfies that each elements in row-i multiplied with ai and each elements in column-j divided by bj, after this operation every element in this matrix is between L and U, L indicates the lowerbound and U indicates the upperbound of these elements.
 

Input
There are several test cases. You should process to the end of file.
Each case includes two parts, in part 1, there are four integers in one line, N,M,L,U, indicating the matrix has N rows and M columns, L is the lowerbound and U is the upperbound (1<=N、M<=400,1<=L<=U<=10000). In part 2, there are N lines, each line includes M integers, and they are the elements of the matrix.

 

Output
If there is a solution print "YES", else print "NO".
 

Sample Input
  
  
3 3 1 6 2 3 4 8 2 6 5 2 9
 

Sample Output
  
  
YES
 

Source
解题思路:等价于L<=c[i][j]*a[i]/b[j]<=R转化为logL-logc[i][j]<=logi-logj<=logR-logc[i][j],用栈比用队列快,负环判定条件为cnt[ed]>sqrt(n);
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <cmath>
#include <stack>
#define Maxn 1005
#define Inf 0x3f3f3f3f
using namespace std;
struct
{
	int e,next;
	double w;
}edge[Maxn*Maxn*2];
int head[Maxn],k;
void add(int s,int e,double w)
{
	edge[k].e=e;
	edge[k].w=w;
	edge[k].next=head[s];
	head[s]=k++;
}
bool spfa(int n)
{
	int i,st,ed,cnt[Maxn];
	double dis[Maxn];
	bool vis[Maxn];
	stack<int> s;
	memset(cnt,0,sizeof(cnt));
	memset(vis,false,sizeof(vis));
	fill(dis,dis+Maxn,Inf*1.0);
	cnt[1]=1;
	dis[1]=0;
	vis[1]=true;
	s.push(1);
	int lim=int(sqrt(n*1.0));
	while(!s.empty())
	{
		st=s.top();
		s.pop();
		vis[st]=false;
		for(i=head[st];i!=-1;i=edge[i].next)
		{
			ed=edge[i].e;
			if(dis[ed]>dis[st]+edge[i].w)
			{
				dis[ed]=dis[st]+edge[i].w;
				if(!vis[ed])
				{
					vis[ed]=true;
					cnt[ed]++;
					if(cnt[ed]>lim)
						return false;
					s.push(ed);
				}
			}
		}
	}
	return true;
}
int main()
{
	int m,n;
	double l,r,c;
	freopen("in.txt","r",stdin);
	freopen("out.txt","w",stdout);
	while(~scanf("%d%d%lf%lf",&m,&n,&l,&r))
	{
		k=0;
		memset(head,-1,sizeof(head));
		l=log(l);
		r=log(r);
		for(int i=1;i<=m;i++)
			for(int j=1;j<=n;j++)
			{
				scanf("%lf",&c);
				c=log(c);
				add(j+m,i,r-c);
				add(i,j+m,c-l);
			}
		printf("%s\n",spfa(m+n)?"YES":"NO");
	}
	return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值