POJ 3416 Crossing

Crossing
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 1564 Accepted: 726

Description

Wintokk has collected a huge amount of coins at THU. One day he had all his coins fallen on to the ground. Unfortunately, WangDong came by and decided to rob Wintokk of the coins.

They agreed to distribute the coins according to the following rules:

Consider the ground as a plane. Wintokk draws a horizontal line on the plane and then WangDong draws a vertical one so that the plane is divided into 4 parts, as shown below.

Wintokk will save the coins in I and III while those fit in II and IV will be taken away by the robber WangDong.

For fixed locations of the coins owned by Wintokk, they drew several pairs of lines. For each pair, Wintokk wants to know the difference between the number of the saved coins and that of the lost coins.

It's guaranteed that all the coins will lie on neither of the lines drew by that two guys.

Input

The first line contains an integer T, indicating the number of test cases. Then T blocks of test cases follow. For each case, the first line contains two integers N and M, where N is the number of coins on the ground and M indicates how many times they are going to draw the lines. The 2nd to (N+1)-th lines contain the co-ordinates of the coins and the last M lines consist of the M pairs integers (xy) which means that the two splitting lines intersect at point (xy).

(N,≤ 50000, 0 ≤x,≤ 500000)

Output

For each query, output a non-negative integer, the difference described above. Output a blank line between cases.

Sample Input

2
10 3
29 22
17 14
18 23
3 15
6 28
30 27
4 1
26 7
8 0
11 21
2 25
5 10
19 24
10 5
28 18
2 29
6 5
13 12
20 27
15 26
11 9
23 25
10 0
22 24
16 30
14 3
17 21
8 1
7 4

Sample Output

6
4
4

2
2
4
4
4

Source

解题思路:用两个树状数组维护原点左右两边硬币的个数,先把硬币及原点排序,把所有点插入到右边的树状数组中,取所有在原点左边的点加入到左边树状数组中,同时从右边的树状数组中删除,分别统计下一三象限和二四象限的值相减求绝对值即可
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int l[500005],r[500005];
struct P
{
	int x;
	int y;
	int id;
}point[50005],coin[50005];
int cmp(P a,P b)
{
	if(a.x!=b.x)
		return a.x<b.x;
	else
		return a.y<b.y;
}
int lowbit(int x)
{return x&(-x);}
void add(int *s,int pos,int n,int val)
{
	int i;
	for(i=pos;i<=n;i+=lowbit(i))
		s[i]+=val;
}
int sum(int *s,int pos)
{
	int i,sum=0;
	for(i=pos;i>0;i-=lowbit(i))
		sum+=s[i];
	return sum;
}
int main()
{
	int i,t,n,m,ans[50005],y;
	scanf("%d",&t);
	while(t--)
	{
		y=-1;
		memset(l,0,sizeof(l));
		memset(r,0,sizeof(r));
		memset(ans,0,sizeof(ans));
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;i++)
		{
			scanf("%d%d",&coin[i].x,&coin[i].y);
			coin[i].x++;coin[i].y++;
			if(y<coin[i].y)
				y=coin[i].y;
		}
		sort(coin+1,coin+1+n,cmp);
		for(i=1;i<=m;i++)
		{
			scanf("%d%d",&point[i].x,&point[i].y);
			point[i].x++;point[i].y++;
			point[i].id=i;
			if(y<point[i].y)
				y=point[i].y;
		}
		sort(point+1,point+1+m,cmp);
		for(i=1;i<=n;i++)
			add(r,coin[i].y,y,1);
		int op=1;
		for(i=1;i<=m;i++)
		{
			while(point[i].x>=coin[op].x&&op<=n)
			{
				add(l,coin[op].y,y,1);
				add(r,coin[op].y,y,-1);
				op++;
			}
			int a=sum(r,y)-sum(r,point[i].y)+sum(l,point[i].y);
			int b=sum(l,y)-sum(l,point[i].y)+sum(r,point[i].y);
			ans[point[i].id]=abs(a-b);
		}
		for(i=1;i<=m;i++)
			printf("%d\n",ans[i]);
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值