HDU 2807 The Shortest Path

The Shortest Path

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2436    Accepted Submission(s): 781


Problem Description
There are N cities in the country. Each city is represent by a matrix size of M*M. If city A, B and C satisfy that A*B = C, we say that there is a road from A to C with distance 1 (but that does not means there is a road from C to A).
Now the king of the country wants to ask me some problems, in the format:
Is there is a road from city X to Y?
I have to answer the questions quickly, can you help me?
 

Input
Each test case contains a single integer N, M, indicating the number of cities in the country and the size of each city. The next following N blocks each block stands for a matrix size of M*M. Then a integer K means the number of questions the king will ask, the following K lines each contains two integers X, Y(1-based).The input is terminated by a set starting with N = M = 0. All integers are in the range [0, 80].
 

Output
For each test case, you should output one line for each question the king asked, if there is a road from city X to Y? Output the shortest distance from X to Y. If not, output "Sorry".
 

Sample Input
  
  
3 2 1 1 2 2 1 1 1 1 2 2 4 4 1 1 3 3 2 1 1 2 2 1 1 1 1 2 2 4 3 1 1 3 0 0
 

Sample Output
  
  
1 Sorry
 

Source

HDU 2009-4 Programming Contest

解题思路:给定一些城市,城市用一个矩阵表示,若A*B=C,则代表这两个城市之间有一条通路,求X到Y是否有通路,关键在于矩阵的判定,如何判定A*B=C,考虑到矩阵乘法是满足结合律的,我们设有一个向量v则若v*A*B=V*C,这样就能把矩阵的维数降下来,接下来floyd随便搞搞就行了

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define Inf 99999999
int matrix[85][85][85],vec[85][85],map[85][85];
bool cmp(int b,int m)
{
    int i;
    for(i=1;i<=m;i++)
        if(vec[0][i]!=vec[b][i])
            return false;
    return true;
}
void mul(int a,int b,int n,int m)
{
    int i,j,k,s;
    for(i=1;i<=m;i++)
    {
        vec[0][i]=0;
        for(j=1;j<=m;j++)
            vec[0][i]+=matrix[a][i][j]*vec[b][j];
    }
    for(i=1;i<=n;i++)
        if(i==a||i==b)
            continue;
        else if(cmp(i,m))
            map[a][i]=1;
}
void floyd(int n)
{
    int i,j,k;
    for(k=1;k<=n;k++)
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
                map[i][j]=min(map[i][j],map[i][k]+map[k][j]);
}
int main()
{
    int i,j,k,m,n,a,b;
    while(~scanf("%d%d",&n,&m),m+n)
    {
        memset(matrix,0,sizeof(matrix));
        memset(vec,0,sizeof(vec));
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
                if(i==j)
                    map[i][j]=0;
                else
                    map[i][j]=Inf;
        for(i=1;i<=n;i++)
            for(j=1;j<=m;j++)
                for(k=1;k<=m;k++)
                    scanf("%d",&matrix[i][j][k]);
        for(i=1;i<=n;i++)
            for(j=1;j<=m;j++)
                for(k=1;k<=m;k++)
                    vec[i][j]+=matrix[i][j][k]*k;
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
                if(i==j)
                    continue;
                else 
                    mul(i,j,n,m);    
        floyd(n);
        scanf("%d",&k);
        while(k--)
        {
            scanf("%d%d",&a,&b);
            if(map[a][b]==Inf)
                printf("Sorry\n");
            else
                printf("%d\n",map[a][b]);
        }
    }
    return 0;
}


评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值