HDU 3008 Warcraft

Warcraft

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1126    Accepted Submission(s): 572


Problem Description
Have you ever played the Warcraft?It doesn't matter whether you have played it !We will give you such an experience.There are so many Heroes in it,but you could only choose one of them.Each Hero has his own skills.When such a Skill is used ,it costs some MagicValue,but hurts the Boss at the same time.Using the skills needs intellegence,one should hurt the enemy to the most when using certain MagicValue.

Now we send you to complete such a duty to kill the Boss(So cool~~).To simplify the problem:you can assume the LifeValue of the monster is 100, your LifeValue is 100,but you have also a 100 MagicValue!You can choose to use the ordinary Attack(which doesn't cost MagicValue),or a certain skill(in condition that you own this skill and the MagicValue you have at that time is no less than the skill costs),there is no free lunch so that you should pay certain MagicValue after you use one skill!But we are good enough to offer you a "ResumingCirclet"(with which you can resume the MagicValue each seconds),But you can't own more than 100 MagicValue and resuming MagicValue is always after you attack.The Boss is cruel , be careful!
 

Input
There are several test cases,intergers n ,t and q (0<n<=100,1<=t<=5,q>0) in the first line which mean you own n kinds of skills ,and the "ResumingCirclet" helps you resume t points of MagicValue per second and q is of course the hurt points of LifeValue the Boss attack you each time(we assume when fighting in a second the attack you show is before the Boss).Then n lines follow,each has 2 intergers ai and bi(0<ai,bi<=100).which means using i skill costs you ai MagicValue and costs the Boss bi LifeValue.The last case is n=t=q=0.
 

Output
Output an interger min (the minimun time you need to kill the Boss)in one line .But if you die(the LifeValue is no more than 0) ,output "My god"!
 

Sample Input
  
  
4 2 25 10 5 20 10 30 28 76 70 4 2 25 10 5 20 10 30 28 77 70 0 0 0
 

Sample Output
  
  
4 My god
Hint
Hint: When fighting,you can only choose one kind of skill or just to use the ordinary attack in the whole second,the ordinary attack costs the Boss 1 points of LifeValue,the Boss can only use ordinary attack which costs a whole second at a time.Good Luck To You!
 

Source
解题思路:给你一个英雄,英雄有k种魔法攻击输出,每种魔法攻击需消耗一定的MP,同时对boss造成一定的损伤,也可以直接物理攻击,无需消耗魔法,造成1HP的损伤,同时英雄有魔法光环加成,每回合回复一定量的魔法,boss每个回合对你造成一定的伤害,问你能否在挂掉之前秒掉boss,可以的话求最小的回合数。转化为完全背包求解,把攻击看做一种消耗回合数和魔法值(物理攻击消耗魔法值为0)的物品,求这些物品装入回合数限定的背包内的最大价值,恢复光环可以看做减少MP消耗的一种方法,转化为物品的消耗即可
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    int n,m,t,q,i,j,k,val[105],cost[105],dp[105][105];
    bool flag;
    while(scanf("%d%d%d",&n,&t,&q),n+t+q)
    {
        flag=false;
        memset(val,0,sizeof(val));
        memset(cost,0,sizeof(cost));
        memset(dp,0,sizeof(dp));
        val[1]=1;cost[1]=0;
        for(i=2;i<=n+1;i++)
            scanf("%d%d",cost+i,val+i);
        m=100%q?100/q+1:100/q;
        for(i=1;i<=n+1;i++)
            for(j=1;j<=m;j++)
                for(k=cost[i];k<=100;k++)
                {
                    if(cost[i]>=(j-1)*t)
                        dp[j][k]=max(dp[j][k],dp[j-1][k-cost[i]+(j-1)*t]+val[i]);
                    else
                        dp[j][k]=max(dp[j][k],dp[j-1][k]+val[i]);
                }
        for(i=1;i<=m;i++)
            if(dp[i][100]>=100)
            {
                flag=true;
                break;
            }
        if(flag)
            printf("%d\n",i);
        else
            printf("My god\n");
    }
    return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值