HDU 3664 Permutation Counting

Permutation Counting

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1330    Accepted Submission(s): 669


Problem Description
Given a permutation a1, a2, … aN of {1, 2, …, N}, we define its E-value as the amount of elements where ai > i. For example, the E-value of permutation {1, 3, 2, 4} is 1, while the E-value of {4, 3, 2, 1} is 2. You are requested to find how many permutations of {1, 2, …, N} whose E-value is exactly k.
 

Input
There are several test cases, and one line for each case, which contains two integers, N and k. (1 <= N <= 1000, 0 <= k <= N). 
 

Output
Output one line for each case. For the answer may be quite huge, you need to output the answer module 1,000,000,007.
 

Sample Input
  
  
3 0 3 1
 

Sample Output
  
  
1 4
Hint
There is only one permutation with E-value 0: {1,2,3}, and there are four permutations with E-value 1: {1,3,2}, {2,1,3}, {3,1,2}, {3,2,1}
 

Source
解题思路:给你1到n的n个数的全排列,求使得a[i]>i的数恰有k个方案的个数
令dp[i][j]表示i个数有j个a[i]>i的方案数,对于dp[i-1][j-1],最后一个数我们可以使它与a[i]<=i的任意一个数交换,共有(i-1-(j-1)) 种可能,对于dp[i-1][j],它要么直接放在最后一位,要么与a[i]>i的任意一个数交换,共有(j+1)种可能,所以
dp[i][j]=dp[i-1][j-1]*(i-j)+dp[i-1][j]*(j+1);
#include<cstdio>
#include<iostream>
using namespace std;
const int MAXN=1001;
long long dp[MAXN][MAXN];
const long long MOD=1000000007;
int main()
{
    int n,k;
    int i,j;
    for(i=1;i<=1000;i++)
    {
        dp[i][0]=1;
        for(j=1;j<i;j++)
          dp[i][j]=(dp[i-1][j]+dp[i-1][j]*j+dp[i-1][j-1]*(i-j))%MOD;
    } 
    while(scanf("%d%d",&n,&k)!=EOF)
      printf("%I64d\n",dp[n][k]);
    return 0;  
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值