POJ 1330 Nearest Common Ancestors

Nearest Common Ancestors
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13065 Accepted: 6969

Description

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below:


In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is.

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y.

Write a program that finds the nearest common ancestor of two distinct nodes in a tree.

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output

4
3

Source

Taejon 2002

解题思路:这道题我是用一个数组保存树上的所有边,再利用邻接表把所求的两个节点的祖先节点分别录入ancestor1和ancestor2两个数组中,最后求他们的第一个交集,即是答案,网上有大神用链式前向星做,表示膜拜。吧两种代码均附上。

我的代码:

#include<iostream>
using namespace std;
int main()
{
	int i,j,k,p,q,test,num,n1,n2,c1,c2,rear;
	int parent[10010],ancestor1[10010],ancestor2[10010];
	bool flag;
	cin>>test;
	while(test--)
	{
		j=1;k=1;flag=false;
		memset(parent,0,sizeof(parent));
		memset(ancestor1,0,sizeof(ancestor1));
		memset(ancestor2,0,sizeof(ancestor2));
		cin>>num;
		for(i=1;i<num;i++)
		{
			cin>>n1>>n2;
			parent[n2]=n1;
		}
		    cin>>c1>>c2;
			ancestor1[0]=c1;
			ancestor2[0]=c2;
			rear=c1;
        do
		{
			ancestor1[j]=parent[rear];
			rear=parent[rear];
			j++;
		}while(parent[rear]!=0);
		    rear=c2;
		do
		{
			ancestor2[k]=parent[rear];
			rear=parent[rear];
			k++;
		}while(parent[rear]!=0);
		for(p=0;p<j;p++)
			{for(q=0;q<k;q++)
				if(ancestor1[p]==ancestor2[q])
		           {
					   cout<<ancestor1[p]<<endl;
					   flag=true;
					   break;
				   }
				if(flag)
					break;
		     }
	}
	return 0;
}


链式前向星:

#include <stdio.h>
#include <string.h>
#define MAXN 10010
struct Edge{
	int to;
	int next;
};

Edge edge[MAXN+10];
int head[MAXN+10],p[MAXN+10],qx,qy;
bool bFind,isroot[MAXN+10],visit[MAXN+10];

int find(int x){
	if (p[x]!=x)	p[x] = find(p[x]);
	return p[x];
}

void LCA(int u){
	p[u] = u;
	visit[u]=true;

	for (int k=head[u]; k!=-1; k=edge[k].next)
		if (!visit[edge[k].to])
		{
			LCA(edge[k].to);
			p[edge[k].to]=u;
			if (bFind)	return;
		}

	if (u==qx && visit[qy])
	{
		printf("%d\n",find(qy));
		bFind = true;
		return;
	}
	if (u==qy && visit[qx])
	{
		printf("%d\n",find(qx));
		bFind = true;
		return;
	}
}

int main()
{
	int t,n,i,s,e,rear;
	scanf_s("%d",&t);
	while (t--)
	{
		rear=0;
		scanf_s("%d",&n);
		memset(head,-1,sizeof(head));
		memset(isroot,true,sizeof(isroot));
		memset(visit,0,sizeof(visit));

		for (i=1;i<n;i++)
		{
			scanf_s("%d %d",&s,&e);	//链式前向星
			isroot[e] = false;
			edge[rear].to = e;
			edge[rear].next = head[s];
			head[s] = rear++;
		}
		scanf_s("%d %d",&qx,&qy);

		for (i=1;i<=n;i++)		//找到根节点
			if (isroot[i])	break;
		bFind = false;
		LCA(i);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值