POJ 2586 Y2K Accounting Bug

Y2K Accounting Bug
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7356 Accepted: 3640

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612
Deficit

Source

解题思路:首先要读懂题意,某公司每5个连续的月份出一次五个月的总盈亏报表,因此一共有5,6,7,8,9,10,11,12,八份报表,现已知八份报表都是亏损的,给定单个月份的盈与亏,求该公司一年下来能否盈利,能的话输出盈利最大值,否则输出Deficit;用贪心的思路,若要尽可能多盈利少亏损而连续五个月的表报又呈现亏损的话,只需判定给定单月盈亏比例即可。若是盈亏比大于1:4,那么全年盈亏为dddddddddddd;若是盈亏比大于4:1,则全年盈亏为ssssdssssdss;若是盈亏比在4:1到3:2之间,则全年盈亏为sssddsssddss;若是盈亏比在3:2到2:3之间,则全年盈亏为ssdddssdddss;若是盈亏在2:3到1:4之间,则全年盈亏为sddddsddddsd;最后按上述情况算出一年盈亏之和正数则输出该数,负数则输出Defitct。
#include<iostream>
using namespace std;
int main()
{
	long s,d,ans;
	while(cin>>s>>d)
	{
		ans=0;
		if(s>d*4)
			ans=-1;
		else if(s*4<=d)
			ans=10*s-2*d;
		else if(s*3<=d*2)
			ans=8*s-4*d;
		else if(s*2<=d*3)
			ans=6*s-6*d;
		else if(s<=d*4)
			ans=3*s-9*d;
		else
			ans=-1;
		if(ans>0)
			cout<<ans<<endl;
		else
			cout<<"Deficit"<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值