POJ 2253 Frogger

Frogger
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18781 Accepted: 6122

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

Source

解题思路:求一条路径上的最大值,比较多个路径的最大值,求其中的最小值即是答案,Floyd的变型,状态方程由min{map[i][j],map[i][k]+map[j][k]}变为min{map[i][j],max{map[i][k],map[j][k]}},注意用cout<<setprecision(3)<<fixed控制输出格式,还有坑爹的就是答案之间要输出两个空行,不是题目Sample里的一个啊,我被坑了两次PE啊,有木有!一定要引此为鉴啊!

#include<iostream>
#include<cmath>
#include<iomanip>
using namespace std;
double map[500][500];
int n;
struct
{
	double x,y;
}stone[500];
inline double max(int a,int b)
{return a>b?a:b;}
void Floyd()
{
	int i,j,k;
	for(k=1;k<=n;k++)
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				if(map[i][j]>max(map[i][k],map[k][j]))
					map[i][j]=max(map[i][k],map[k][j]);
}
int main()
{
	int i,j,test=0;
	double a,b,len;
	while(cin>>n&&n)
	{
		for(i=0;i<500;i++)
			for(j=0;j<500;j++)
				map[i][j]=1000000.0;
		for(i=1;i<=n;i++)
		{
			cin>>stone[i].x>>stone[i].y;
			for(j=1;j<n;j++)
			{
				a=stone[i].x-stone[j].x;
				b=stone[i].y-stone[j].y;
				len=sqrt(pow(a,2.0)+pow(b,2.0));
				map[i][j]=map[j][i]=len;
			}
		}
		for(i=1;i<=n;i++)
			map[i][i]=0.0;
		Floyd();
		if(!test)
            cout<<setprecision(3)<<fixed;
		cout<<"Scenario #"<<++test<<endl<<"Frog Distance = "<<map[1][2]<<endl<<endl;
	}
	cout<<endl;
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值