coprime sequence

Do you know what is called ``Coprime Sequence''? That is a sequence consists of nnpositive integers, and the GCD (Greatest Common Divisor) of them is equal to 1. 
``Coprime Sequence'' is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.

Input

The first line of the input contains an integer T(1≤T≤10)T(1≤T≤10), denoting the number of test cases. 
In each test case, there is an integer n(3≤n≤100000)n(3≤n≤100000) in the first line, denoting the number of integers in the sequence. 
Then the following line consists of nn integers a1,a2,...,an(1≤ai≤109)a1,a2,...,an(1≤ai≤109), denoting the elements in the sequence.

Output

For each test case, print a single line containing a single integer, denoting the maximum GCD.

Sample Input

3
3
1 1 1
5
2 2 2 3 2
4
1 2 4 8

Sample Output

1
2
2
#include<stdio.h>
#include<algorithm>

using namespace std;

const int maxn = 1e5 + 10;
int a[maxn], b[maxn], c[maxn];

int gcd(int a, int b){
	return b ? gcd(b, a % b) : a;
}

int main()
{
	int t;
	scanf ("%d", &t);
	while(t--){
		int n; scanf ("%d", &n);
		for (int i = 0; i < n; i++)
			scanf ("%d", a+i);
		b[0] = a[0], c[n-1] = a[n-1];
		for (int i = 1; i < n; i++) // 求前缀gcd 
			b[i] = gcd(b[i-1], a[i]);
		for (int i = n-2; i >= 0; i--) // 求后缀gcd 
			c[i] = gcd(c[i+1], a[i]);
		int ans = max(b[n-2], c[1]);
		for (int i = 1; i < n-1; i++) //遍历求最大值 
			ans = max(ans, gcd(b[i-1], c[i+1]));
		printf ("%d\n", ans);
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值