Compromise [LCS + 打印路径]

In a few months the European Currency Union will become a reality. However, to join the club, the Maastricht criteria must be fulfilled, and this is not a trivial task for the countries (maybe except for Luxembourg). To enforce that Germany will fulfill the criteria, our government has so many wonderful options (raise taxes, sell stocks, revalue the gold reserves,…) that it is really hard to choose what to do.

Therefore the German government requires a program for the following task:
Two politicians each enter their proposal of what to do. The computer then outputs the longest common subsequence of words that occurs in both proposals. As you can see, this is a totally fair compromise (after all, a common sequence of words is something what both people have in mind).

Your country needs this program, so your job is to write it for us.
Input
The input will contain several test cases.
Each test case consists of two texts. Each text is given as a sequence of lower-case words, separated by whitespace, but with no punctuation. Words will be less than 30 characters long. Both texts will contain less than 100 words and will be terminated by a line containing a single ‘#’.
Input is terminated by end of file.
Output
For each test case, print the longest common subsequence of words occuring in the two texts. If there is more than one such sequence, any one is acceptable. Separate the words by one blank. After the last word, output a newline character.
Sample Input
die einkommen der landwirte
sind fuer die abgeordneten ein buch mit sieben siegeln
um dem abzuhelfen
muessen dringend alle subventionsgesetze verbessert werden
#
die steuern auf vermoegen und einkommen
sollten nach meinung der abgeordneten
nachdruecklich erhoben werden
dazu muessen die kontrollbefugnisse der finanzbehoerden
dringend verbessert werden
#
Sample Output
die einkommen der abgeordneten muessen dringend verbessert werden

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

char str_1[105][35], str_2[105][35];
int len_1, len_2;
int dp[105][35], path[105];

int main() {
    while (~ scanf ("%s", str_1[len_1 = 1])) {
        while (str_1[len_1][0] != '#') {
            scanf ("%s", str_1[++ len_1]);
        }
        len_2 = 1;
        scanf ("%s", str_2[len_2]);
        while (str_2[len_2][0] != '#') {
            scanf ("%s", str_2[++len_2]);
        }
        len_1 --; len_2 --;
        memset (dp, 0, sizeof(dp));
        memset (path, 0, sizeof(path));
        for (int i = 1; i <= len_1; ++i) {
            for (int j = 1; j <= len_2; ++j) {
                if (!strcmp(str_1[i], str_2[j])) 
                    dp[i][j] = dp[i - 1][j - 1] + 1;
                else dp[i][j] = max (dp[i - 1][j], dp[i][j - 1]);
            }
        }
        int i = len_1, j = len_2, k = 0;
        while (dp[i][j]) {
            if (dp[i][j] == dp[i - 1][j]) i --;
            else if (dp[i][j] == dp[i][j - 1]) j --;
            else {
                path[k++] = i;
                i --; j --;
            }
        }
        for (int i = k - 1; i > 0; i--)
            cout << str_1[path[i]] << " ";
        cout << str_1[path[0]] << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值