HDU 4726 Kia's Calculation

Kia's Calculation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 615    Accepted Submission(s): 174


Problem Description
Doctor Ghee is teaching Kia how to calculate the sum of two integers. But Kia is so careless and alway forget to carry a number when the sum of two digits exceeds 9. For example, when she calculates 4567+5789, she will get 9246, and for 1234+9876, she will get 0. Ghee is angry about this, and makes a hard problem for her to solve:
Now Kia has two integers A and B, she can shuffle the digits in each number as she like, but leading zeros are not allowed. That is to say, for A = 11024, she can rearrange the number as 10124, or 41102, or many other, but 02411 is not allowed.
After she shuffles A and B, she will add them together, in her own way. And what will be the maximum possible sum of A "+" B ?
 

Input
The rst line has a number T (T <= 25) , indicating the number of test cases.
For each test case there are two lines. First line has the number A, and the second line has the number B.
Both A and B will have same number of digits, which is no larger than 10 6, and without leading zeros.
 

Output
For test case X, output "Case #X: " first, then output the maximum possible sum without leading zeros.
 

Sample Input
  
  
1 5958 3036
 

Sample Output
  
  
Case #1: 8984
 

Source


分析:贪心。


Code:

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#define Min(a,b) ((a)<(b)?(a):(b))
using namespace std;

const int maxn=1000005;
int s[2][10],ans[maxn];
char s1[maxn],s2[maxn];
int T,cnt,cas=1;

int get_x(int x) {
    int num=0,mx;
    for(int i=0;i<=9;i++) {
        for(int j=0;j<=9;j++) {
            int tmp=(i+j)%10;
            if(tmp==x) {
                mx=Min(s[0][i],s[1][j]);
                num+=mx;
                s[0][i]-=mx;
                s[1][j]-=mx;
                mx=Min(s[1][i],s[0][j]);
                num+=mx;
                s[1][i]-=mx;
                s[0][j]-=mx;
            }
        }
    }
    return num;
}

bool get_head() {
    for(int k=9;k>0;k--) {
        for(int i=1;i<=9;i++) {
            for(int j=1;j<=9;j++) {
                int tmp=(i+j)%10;
                if(tmp==k) {
                    if(s[0][i] && s[1][j]) {
                        s[0][i]--; s[1][j]--;
                        ans[0]=k;
                        return true;
                    }
                    else if(s[0][j] && s[1][i]) {
                        s[0][j]--; s[1][i]--;
                        ans[0]=k;
                        return true;
                    }
                }
            }
        }
    }
    return false;
}

void solve(){
    for(int i=9;i>0;i--) {
        int num=get_x(i);
        while(num--) {
            ans[cnt++]=i;
        }
    }
}

int main()
{
    scanf("%d",&T);
    while(T--) {
        scanf("%s %s",s1,s2);
        int len=strlen(s1);
        memset(s,0,sizeof(s));
        for(int i=0;i<len;i++) {
            s[0][s1[i]-'0']++;
            s[1][s2[i]-'0']++;
        }
        cnt=1;
        printf("Case #%d: ",cas++);
        if(!get_head()) {
            printf("0\n");
            continue;
        }
        solve();
        for(int i=0;i<cnt;i++) printf("%d",ans[i]);
        if(cnt<len){
            while(cnt<len) {
                putchar('0');
                cnt++;
            }
        }
        puts("");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值