HDU-3732 Ahui Writes Word

4 篇文章 0 订阅

Problem Description
We all know that English is very important, so Ahui strive for this in order to learn more English words. To know that word has its value and complexity of writing (the length of each word does not exceed 10 by only lowercase letters), Ahui wrote the complexity of the total is less than or equal to C.
Question: the maximum value Ahui can get.
Note: input words will not be the same.
 
Input
The first line of each test case are two integer N , C, representing the number of Ahui’s words and the total complexity of written words. (1 ≤ N ≤ 100000, 1 ≤ C ≤ 10000)
Each of the next N line are a string and two integer, representing the word, the value(Vi ) and the complexity(Ci ). (0 ≤ Vi , Ci ≤ 10)
 
Output
Output the maximum value in a single line for each test case.
 
Sample Input
5 20
go 5 8
think 3 7
big 7 4
read 2 6
write 3 5
 
Sample Output
15

      
      
Hint
Input data is huge,please use “scanf(“%s”,s)”
 



思路:看一下N和C的数据规模,1e9这分分钟TLE的节奏。这时我们看到Vi,Ci的数据范围都是[0,10],那么我们可以将N个单词转换成至多10*10种单词,从而将01背包转换成多重背包来做,用b[i][j]表示value为i,complexity为j的单词的总数即可。


AC代码:

#include<iostream>
#include<algorithm>
#include<string.h>
#include<string>
#include<stdio.h>
#include<math.h>
using namespace std;

typedef long long ll;
typedef unsigned long long ull;
#define min(a,b) (a>b?b:a)
#define max(a,b) (a>b?a:b)
#define mem(a,num) memset(a,num,sizeof(a))
#define inf(a,n) fill(a,a+n,0x3f3f3f3f)

int main()
{
    //ios::sync_with_stdio(false);
    int n,w;
    char a[100005];
    int b[11][11];//b[i][j]表示value为i,complexity为j的单词的总数
    ll dp[10005];
    while(~scanf("%d%d",&n,&w))
    {
        mem(dp,0);
        mem(b,0);
        int v,c;
        for(int i=0;i<n;++i){
            scanf("%s%d%d",a,&v,&c);
            b[v][c]++;
        }
        for(int h=0;h<11;++h)
        for(int i=0;i<11;++i){
            int v,k=1,m,sum=b[h][i];
            while(k<=sum){
                v=i*k;
                m=h*k;
                for(int j=w;j>=v;--j){
                    dp[j]=max(dp[j],dp[j-v]+m);
                }
                sum-=k;
                k<<=1;
            }
            if(sum>0){
                v=i*sum;
                m=h*sum;
                for(int j=w;j>=v;--j){
                    dp[j]=max(dp[j],dp[j-v]+m);
                }
            }
        }
        printf("%lld\n",dp[w]);
    }
	return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

算法之旅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值