Layout POJ - 3169(差分约束) 题解

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.
Input
Line 1: Three space-separated integers: N, ML, and MD.

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.
Output
Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.
Sample Input
4 2 1
1 3 10
2 4 20
2 3 3
Sample Output
27
Hint
Explanation of the sample:

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.


第一次接触查分约束还是有点懵的,利用了最短路的不等式dis[j]>dis[i]+len[i]来考虑不等式的问题,这里i和j要保持距离k以内,就往i到j构造一条长度为k的路径,保持k距离以外,就往j到i构造一条权值为-k的路径,出现负环即为不能构造出来(我决定最后应该再判断每个点的位置才对)。

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;
int n,ml,md;
int from[20005], len[20005], to[20005],dis[1005];
int enumber;
bool is_ans;
void add(int x, int y, int z){
    to[enumber] = y;
    from[enumber] = x;
    len[enumber++] = z;
}

void bellman(){
    for (int i = 1; i <= n; i++){
        bool relax = 0;
        for (int j = 0; j < enumber; j++){
            int a = from[j], b = to[j], c = len[j];
            if (dis[b]>dis[a] + c){
                relax = 1;
                dis[b] = dis[a] + c;
            }
        }
        if (relax == 0)break;
        if (relax&&i == n)is_ans = 0;
    }

}

int main(){
    int x, y, z;
    while (scanf("%d%d%d", &n, &ml, &md) != EOF){
        enumber = 0;
        for (int i = 0; i < ml; i++){
            scanf("%d%d%d", &x, &y, &z);
            if (x > y)swap(x, y);
            add(x, y, z);
        }
        for (int i = 0; i < md; i++){
            scanf("%d%d%d", &x, &y, &z);
            if (x > y)swap(x, y);
            add(y, x, -z);
        }
        memset(dis, 0x3f, sizeof(dis));
        dis[1] = 0;
        is_ans = 1;
        bellman();
        if (is_ans == 0){ printf("-1\n"); }
        else if (dis[n] > 100000000){ printf("-2\n"); }
        else{ printf("%d\n", dis[n]); }
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值