Given the value of N, you will have to find the value of G. The definition of G is given below:
Here GCD(i, j) means the greatest common divisor of integer i and integer j.
For those who have trouble understanding summation notation, the meaning of G is given in the
following code:
G=0;
for(i=1;i < N;i++)
for(j=i+1;j<=N;j++)
{
G+=gcd(i,j);
}
/*Here gcd() is a function that finds
the greatest common divisor of the two
input numbers*/
Input
The input file contains at most 100 lines of inputs. Each line contains an integer N (1 < N < 4000001).
The meaning of N is given in the problem statement. Input is terminated by a line containing a single
zero.
Output
For each line of input produce one line of output. This line contains the value of G for the corresponding
N. The value of G will fit in a 64-bit signed integer.
Sample Input
10
100
200000
0
Sample Output
67
13015
143295493160
白书上面的题目,给定的n要求求出gcd(1,2)到gcd(n-1,n)的值之和,暴力应该是不行的了,应该找找这些gcd有什么共通性,设f[x]是gcd(1,x)到gcd(x-1,x)的和,我们所需要的就是求出f[x]+…+f[n],对于gcd(1,x)到gcd(x-1,x)任意gcd的值,肯定是1到x的一个值,所以可以枚举i使gcd(k,x)=i,f[x]=sum(i*【gcd(k,x)==i的k的数量】),而对于任意一个gcd(k,x)=i,有gcd(k/i,x/i)=1,也就是与x/i互质且小于x/i的数字的数量,通过预处理phi数组可以O(1)得到。同时,枚举i效率比较慢,因为gcd(k,x)=i满足有解的i只能是x的因数(因为gcd求的就是最大公因数),所以枚举i的倍数来更新f[x]的效率更高。
#include<iostream>
#include<algorithm>
#include<string.h>
#include<stdio.h>
#include<vector>
#include<string>
#include<queue>
using namespace std;
#define ll long long
#define inf 0x3f3f3f3f
const int maxe = 30005;
const int maxk = 505;
const int mod = 1000000000;
const int maxn = 4000005;
int n;
ll f[maxn];//f[x]=gcd(1,x)+gcd(2,x)+...gcd(x-1,x)
ll s[maxn];//s[x]=f[1]+f[2]+...+f[x]
ll phi[maxn];
void phi_init(){
memset(phi, 0, sizeof phi);
phi[1] = 1;
for (int i = 2; i<maxn; i++){
if (phi[i] == 0){
for (int j = i; j<maxn; j += i){
if (!phi[j]){
phi[j] = j;
}
phi[j] = phi[j] / i*(i - 1);
}
}
}
}
int main(){
phi_init();
for (int i = 1; i<maxn; i++){
for (int j = i * 2; j<maxn; j += i){
f[j] += i*phi[j / i];
}
}
s[2] = f[2];
for (int i = 3; i<maxn; i++){ s[i] = s[i - 1] + f[i]; }
while (~scanf("%d", &n),n){
printf("%lld\n", s[n]);
}
return 0;
}