杭电ACM 1003 Max Sum

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 241702    Accepted Submission(s): 57045


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

Author
Ignatius.L
 

Recommend

We have carefully selected several similar problems for you:  1176 1087 1069 2084 1058 



#include<iostream>
#include<algorithm>
using namespace std;
int main(void)
{
	int n,count; //n是一共多少组数据,count是一个数据多少个int
	int Max,sum;//Max是最后求出的最大值,sum是一个不断更新以求出Max的值
	int cnumb = 1;//作格式输出用
	cin >> n;
	while (n)
	{
		cin >> count;
		int *a = new int[count+1];//创立数组
		for (int i = 1; i <= count; i++)//输入 使用i=1来进行操作(符合人常识)
			cin >> a[i];
		int start, end;//开始与结束坐标,按照常识来赋值
		start = end = 1;
		int temp = 1;//中间值:用以保存当sum<0时,下次开始的坐标
		sum = 0;
		Max = -1001; //题目规定 between -1000 and 1000
		for (int j = 1; j <= count; j++)
		{
			sum+= a[j];//不断相加
			if (sum > Max)//使得sum发现新值,如果比Max大就替换,并修改起始位置
			{
				Max = sum;
				start = temp;
				end = j;
			}
			if (sum < 0)  //不用惧怕一组全是负数而被最后输出的是0,因为sum>Max这一步的判断是最先进行的
				          //,肯定会保持Max是目前最大值
			{
				sum = 0;
				temp = j+1;
			}			//sum<0的话,前面的肯定都不会取了,所以修改开始位置,从j之后的一位开始取子序列
		}
		printf("Case %d:\n%d %d %d\n", cnumb++, Max,start,end);
		delete []a;//善后操作
		a = NULL;
		if(n!=1)printf("\n");//不加这个if会使OJ显示presentation wrong 因为会多数输出一个回车
		n--;
	}
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值