PTA 03-树2 List Leaves

简单讲下思路:叶子,顾名思义就是没有左右子树的结点。由于题目要求,叶子结点的输出顺序是从上往下,从左往右。所以用层序遍历法。

当然,这里先找到root树的根。运用队列,将root进队列。然后依次将队头出队,若是叶子则输出,否则且将其有的左右孩子进队,达到层序遍历,就是从上往下,从左往右的要求。

当队列为空,即遍历整个树后,结束。

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

4 1 5

#include<stdio.h>
#include <ctype.h>

#define MaxTree 10
#define ElementType char
#define Tree int 
#define Null -1
//建立结构体
struct TreeNode
{	Tree Left;
	Tree Right;
}T1[MaxTree];
//定义函数
Tree BuildTree(struct TreeNode T[]);
void IsLeave(Tree R1);

int main(void)
{
	//int i;
	Tree R1;
	R1 = BuildTree(T1);
	//printf("%d\n",R1);
	IsLeave(R1);
	//scanf("%d",&i);
	return 0;
}
Tree BuildTree(struct TreeNode T[]){
    int N;
    char cl, cr;
    Tree Root = Null;
    scanf("%d", &N);
    int check[MaxTree];
    if(N){
        for(int i=0; i<N; ++i) check[i]=0;
        for(int i=0; i<N; ++i){
            scanf(" %c %c", &cl, &cr);
            if(cl!='-'){
                T[i].Left = cl - '0';
                check[T[i].Left] = 1;
            }else T[i].Left = Null;

            if(cr!='-'){
                T[i].Right = cr - '0';
                check[T[i].Right] = 1;
            }else T[i].Right = Null;
        }
        for(int i=0; i<N; ++i){
            if(!check[i]){
                Root = i;
                break;
            }
        }
    }
    return Root;    
}
//构造完树后,层序遍历树,依次输出叶节点;层序遍历过程:从根节点开始依次将左右儿子入队,直到队列为空  
void IsLeave(Tree R1)
{
    int leaves = 0;         //记录输出叶节点个数,方便输出时第一个节点输出前没有空格  
	int queue[10]={-1};          //节点队列,只保存节点下标  
    int head = 0, rear = 0;  
    queue[rear++] = R1;   //根节点入队
	while(rear-head)
	{
		int node = queue[head++];
		if((T1[node].Left == -1)&&(T1[node].Right == -1))
		{	if(leaves)printf(" ");
			printf("%d",node);
			++leaves;
		}
		if(T1[node].Left!=-1)//如果存在,左儿子入队
			queue[rear++]=T1[node].Left;
		if(T1[node].Right!=-1)//如果存在,右儿子入队
			queue[rear++]=T1[node].Right;
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值