【解题报告】uva674_Coin Change(硬币找零, dp, 完全背包)

16 篇文章 0 订阅
12 篇文章 0 订阅

674 - Coin Change

Time limit: 3.000 seconds


  Coin Change 

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.


For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.


Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

Input 

The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

Output 

For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

Sample Input 

11
26

Sample Output 

4
13


题目大意:

有5种面值的硬币,面值分别为1、5、10、25、50。给定所需找零的金额数,求用上述硬币找零,共有多少种硬币的组合方式(不考虑硬币顺序,如[1,5]和[5,1]为一种组合方式)。


解题思路:

完全背包问题。定义状态d(i,j),代表用前i种硬币组合出金额i时的组合方式。

状态转移方程:d(i,j) = ∑{ dp(i-1,j-c[i]*k) | 1<=k<=j/c[i], c[i]∈{1,5,10,25,50} }

由于不考虑硬币顺序,计算时先枚举硬币种类c[j],其次枚举所有找零金额状态,确保每种硬币不会被重复计算。             

#include <cstdio>

int c[5]={1,5,10,25,50};
int d[7490];

int main()
{
    d[0]=1;
    for(int j=0;j<5;++j){
        for(int i=c[j];i<=7489;++i){
            d[i]+=d[i-c[j]];
        }
    }
    int n;

    while(~scanf("%d",&n)) printf("%d\n",d[n]);

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值