【解题报告】uva562_Dividing coins(划分硬币, dp, 01背包)

16 篇文章 0 订阅
12 篇文章 0 订阅

562 - Dividing coins

Time limit: 3.000 seconds

 Dividing coins 

It's commonly known that the Dutch have invented copper-wire. Two Dutch men were fighting over a nickel, which was made of copper. They were both so eager to get it and the fighting was so fierce, they stretched the coin to great length and thus created copper-wire.


Not commonly known is that the fighting started, after the two Dutch tried to divide a bag with coins between the two of them. The contents of the bag appeared not to be equally divisible. The Dutch of the past couldn't stand the fact that a division should favour one of them and they always wanted a fair share to the very last cent. Nowadays fighting over a single cent will not be seen anymore, but being capable of making an equal division as fair as possible is something that will remain important forever...


That's what this whole problem is about. Not everyone is capable of seeing instantly what's the most fair division of a bag of coins between two persons. Your help is asked to solve this problem.


Given a bag with a maximum of 100 coins, determine the most fair division between two persons. This means that the difference between the amount each person obtains should be minimised. The value of a coin varies from 1 cent to 500 cents. It's not allowed to split a single coin.

Input 

A line with the number of problems  n , followed by  n  times:
  • a line with a non negative integer m ($m \le 100$) indicating the number of coins in the bag
  • a line with m numbers separated by one space, each number indicates the value of a coin.

Output 

The output consists of  n  lines. Each line contains the minimal positive difference between the amount the two persons obtain when they divide the coins from the corresponding bag.

Sample Input 

2
3
2 3 5
4
1 2 4 6

Sample Output 

0
1



Miguel A. Revilla 
1998-03-10



题目大意:

首先输入n,代表有n组测试数据。每组数据2行,第一行为正整数m(0<=m<=100),代表有m个硬币,第二行m个正整数ci(1<=ci<=500),代表每个硬币的面值。求把硬币分给2个人,使得他们所得的总金额差值最小。


解题思路:

01背包判断可行性。定义状态d(i,j),代表用前i种硬币组合出金额j的可行性,值为1代表可行,为0代表不行。

d(i,j) = { d(i-1,j-c[i]) | c[i]<=j, d(i-1,j-c[i])=1 }

最后遍历所有可行状态,找出最小差值。


#include <cstdio>
#include <cstring>
#define min(a,b) (a<b?a:b)
#define abs(a) ((a)>0?(a):-(a))

int n;//测试数据组数
int m;//硬币数
int total;//硬币总面值
int c[110];//每个硬币的面值
int d[500*100+10];//状态

int main()
{
    //freopen("in.txt","r",stdin);
    scanf("%d",&n);
    while(n--){
        scanf("%d",&m);

        //init
        memset(d,0,sizeof(d));
        d[0]=1,total=0;

        for(int i=0;i<m;++i) scanf("%d",&c[i]),total+=c[i];

        for(int i=0;i<m;++i){//枚举所有硬币
            for(int j=total;j>=c[i];--j){//计算各状态
                if(d[j-c[i]]) d[j]=1;
            }
        }
        int ans=total;//差值最小值

        for(int i=1;i<=total;++i){
            //printf("(%d,%d) ",i,d[i]) ;
            if(d[i]) ans=min(abs(total-i-i),ans);
        }
        printf("%d\n",ans);
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值