POJ_3904_Sky_Code 容斥定理

/*
Sky Code


Time Limit: 1000MS  Memory Limit: 65536K
Total Submissions: 2065  Accepted: 659

Description

Stancu likes space travels but he is a poor software developer and will never be able to
 buy his own spacecraft. That is why he is preparing to steal the spacecraft of Petru.
 There is only one problem – Petru has locked the spacecraft with a sophisticated cryptosystem
  based on the ID numbers of the stars from the Milky Way Galaxy. For breaking the system Stancu
  has to check each subset of four stars such that the only common divisor of their numbers is 1.
   Nasty, isn’t it? Fortunately, Stancu has succeeded to limit the number of the interesting stars
    to N but, any way, the possible subsets of four stars can be too many. Help him to find their
     number and to decide if there is a chance to break the system.

Input

In the input file several test cases are given. For each test case on the first line the number N
of interesting stars is given (1 ≤ N ≤ 10000). The second line of the test case contains the list
of ID numbers of the interesting stars, separated by spaces. Each ID is a positive integer which is
 no greater than 10000. The input data terminate with the end of file.

Output

For each test case the program should print one line with the number of subsets with the asked property.

Sample Input
4
2 3 4 5
4
2 4 6 8
7
2 3 4 5 7 6 8

Sample Output
1
0
34

*/
/*
大意:

给你N个整数,从这N个数中选择4个数,使得这四个数的公约数为1。求满足条件的四元组个数。


思路:


四个数的公约数为1,并不代表四个数两两互质。比如(2,3,4,5)公约数为1,但是2和4并不互质。

从反面考虑,先求出四个数公约数不为1的情况个数,用总的方案个数减去四个数公约数不为1的情况个数就是所求。

因为同一素因子 可能在不同集合,所以利用容斥定理 去重
 
sum =  n*(n-1)*(n-2)*(n-3)/24    表示n个数取任取四个的 总组合数

t  =  由一个素因子组合成的四个数的组合数 - 由两个素因子组合成的四个数的组合数 +.......(容斥定理)

res = sum - t;

*/


#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
long long p[10005];
long long prime[10005];
long long num[10005];
long long cout[10005];
void init()
{
	long long i;
	memset(num,0,sizeof(num));
	memset(p,0,sizeof(p));
	for(i=4;i<=10005;i++)
	{
		p[i] = i * (i-1) * (i-2) * (i-3) / 24;
	}
}
void find(long long x)
{
	long long i,j;
	long long top = 0;
	for(i=2;i*i<=x;i++)
	{
		if(x%i==0)
		{
			prime[top++] = i;
			while(x%i==0)
			{
				x /= i;
			}
		}
	}
	if(x>1)
	{
		prime[top++] = x;
	}
	long long t, sum;
	for(i = 1 ;i < (1<<top); i++)
	{
		t = 1;
		sum = 0;
		for(j=0;j<top;j++)
		{
			if(i & (1<<j))
			{
				t *= prime[j];
				sum ++ ;
			}
		}
		cout[t] ++ ;   //当前因子的个数
		num[t] = sum;  //当前因子是由多少个素因子组成 
	}	
}
int main()
{
	init();
	long long i,j,n,w;
	while(scanf("%lld",&n)!=EOF)
	{
		long long M = - 0x3f3f3f3f;
		memset(cout,0,sizeof(cout));
		for(i=0;i<n;i++)
		{
			scanf("%lld",&w);
			M = max(w,M);
			find(w);
		}
		long long res  = 0;  
		for(i=0;i<M;i++)
		{
			if(cout[i])
			{
				if(num[i]%2)
				{
					res += p[cout[i]];  //容斥定理 奇数加偶数减 
				}
				else
				{
					res -= p[cout[i]];
				}
			}
		}
		printf("%lld\n",p[n]-res);
	} 
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值