Sky Code - POJ 3904 容斥原理

32 篇文章 0 订阅

Sky Code
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1705 Accepted: 528

Description

Stancu likes space travels but he is a poor software developer and will never be able to buy his own spacecraft. That is why he is preparing to steal the spacecraft of Petru. There is only one problem – Petru has locked the spacecraft with a sophisticated cryptosystem based on the ID numbers of the stars from the Milky Way Galaxy. For breaking the system Stancu has to check each subset of four stars such that the only common divisor of their numbers is 1. Nasty, isn’t it? Fortunately, Stancu has succeeded to limit the number of the interesting stars to N but, any way, the possible subsets of four stars can be too many. Help him to find their number and to decide if there is a chance to break the system.

Input

In the input file several test cases are given. For each test case on the first line the number N of interesting stars is given (1 ≤ N ≤ 10000). The second line of the test case contains the list of ID numbers of the interesting stars, separated by spaces. Each ID is a positive integer which is no greater than 10000. The input data terminate with the end of file.

Output

For each test case the program should print one line with the number of subsets with the asked property.

Sample Input

4
2 3 4 5 
4
2 4 6 8 
7
2 3 4 5 7 6 8

Sample Output

1 
0 
34

题意:求最大公约数为1的四元组。

思路:首先算出1-10000的倍数各有多少个,先让ans=C(n,4),然后减去最大公约数为奇数个素数的积的情况,加上最大公约数为偶数个素数的积的情况。

AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
typedef long long ll;
ll n,num[10010],prime[10010];
ll num_p[10010],ret,p[10010],temp;
bool vis[10010];
ll Cal(ll a)
{
    return a*(a-1)*(a-2)*(a-3)/24;
}
void get_sum(int id,int step,int Num)
{
    int i,j;
    if(step>Num)
    {
        ret+=Cal(num_p[temp]);
        return;
    }
    for(i=id;i<=prime[0];i++)
    {
        if(temp*prime[i]>10000)
          return;
        p[step]=prime[i];
        temp*=prime[i];
        get_sum(i+1,step+1,Num);
        temp/=prime[i];
    }
}
int main()
{
    int i,j,k;
    ll ans;
    for(i=2;i<=10000;i++)
       if(!vis[i])
       {
           prime[++prime[0]]=i;
           for(j=i*2;j<=10000;j+=i)
              vis[j]=1;
       }
    while(~scanf("%I64d",&n))
    {
        memset(num,0,sizeof(num));
        memset(num_p,0,sizeof(num_p));
        for(i=1;i<=n;i++)
        {
            scanf("%d",&k);
            num[k]++;
        }
        for(i=1;i<=10000;i++)
        {
            for(j=i;j<=10000;j+=i)
               num_p[i]+=num[j];
        }
        ans=Cal(n);
        for(i=1;i<=8;i++)
        {
            ret=0;
            temp=1;
            get_sum(1,1,i);
            if(i&1)
              ans-=ret;
            else
              ans+=ret;
        }
        printf("%I64d\n",ans);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值