Ignatius and the Princess III
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18994 Accepted Submission(s): 13352
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4
10
20
Sample Output
5
42
另外给上递归算法,非递归的就照着写就可以了
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18994 Accepted Submission(s): 13352
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4
10
20
Sample Output
5
42
627
这道题上算法课时学过,就是求一个整数n的划分种类,这里需要注意一点,我们不能使用递归式,会超时。只能用动态规划来进行打表。
<span style="font-size:18px;">
#include <iostream>
#include<cstdio>
using namespace std;
int dp[125][125];
void init()
{
for (int i = 1;i <= 120;i++)
dp[0][i] = 1;
for (int i = 1;i <= 120;i++)
{
dp[i][0] = 0;
for (int j = 1;j <= 120;j++)
{
if(i < j)
dp[i][j] = dp[i][i];
else
dp[i][j] = (dp[i-j][j]+dp[i][j-1]);
}
}
}
int main()
{
int n;
init();
while(~scanf("%d",&n))
{
printf("%d\n",dp[n][n]);
}
return 0;
}</span>
另外给上递归算法,非递归的就照着写就可以了
#include <iostream>
#include<cstdio>
using namespace std;
int q(int n,int m)
{
if((n<1)||(m<1))
return 0;
if((n==1)||(m==1))
return 1;
if(n<=m)
return(q(n,n-1)+1);
return q(n,m-1)+q(n-m,m);
}
int main()
{
int n;
scanf("%d",&n);
printf("%d\n",q(n,n));
return 0;
}