hdu 1086

                         You can Solve a Geometry Problem too

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10068 Accepted Submission(s): 4977


Problem Description
Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :)
Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point.

Note:
You can assume that two segments would not intersect at more than one point.


Input
Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending.
A test case starting with 0 terminates the input and this test case is not to be processed.


Output
For each case, print the number of intersections, and one line one case.


Sample Input

2
0.00 0.00 1.00 1.00
0.00 1.00 1.00 0.00
3
0.00 0.00 1.00 1.00
0.00 1.00 1.00 0.000
0.00 0.00 1.00 0.00
0



Sample Output

1

3

题意就是判断n个线段的交点个数。

高中数学知识,如果一个线段与另外一个线段相交,则该线段的两个端点一点在另外线段的两侧,并且一定要反过来也成立,因为线段不能无限延长。

两点式写直线方程应该容易

其余的就很简单了

<span style="font-size:18px;">

#include <iostream>
#include<cstdio>

using namespace std;
struct Point
{
    double x1,y1,x2,y2;
}p[110];
bool judge(Point p1,Point p2)
{
    double temp1=(p1.y1-p1.y2)*(p2.x1-p1.x2)/(p1.x1-p1.x2)+p1.y2-p2.y1;
    double temp2=(p1.y1-p1.y2)*(p2.x2-p1.x2)/(p1.x1-p1.x2)+p1.y2-p2.y2;
    if(temp1*temp2<=0)//等于0说明端点在线段上
        return true;
    return false;
}
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        for(int i=0;i<n;i++)
            scanf("%lf%lf%lf%lf",&p[i].x1,&p[i].y1,&p[i].x2,&p[i].y2);
        int cnt=0;
        for(int i=0;i<n;i++){
            for(int j=i+1;j<n;j++){
                if(judge(p[i],p[j])&&judge(p[j],p[i]))//这里非常重要,千万不能只判断一次
                    cnt++;
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}

</span>




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值