4 Values whose Sum is 0
Time Limit: 15000MS Memory Limit: 228000K
Total Submissions: 20042 Accepted: 5987
Case Time Limit: 5000MS
Description
The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input
The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .
Output
For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input
6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
Sample Output
5
Hint
Time Limit: 15000MS Memory Limit: 228000K
Total Submissions: 20042 Accepted: 5987
Case Time Limit: 5000MS
Description
The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input
The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .
Output
For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input
6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
Sample Output
5
Hint
Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).
题意:让你在四个数组中分别找出一个数,使得 a + b + c + d = 0 .并且(a, b, c, d ) ∈ A x B x C x D ,这题跟我们之前做过的三个数组的差不多。在这里,直接枚举O(n^4)想都不要想,直接爆炸。我们可以将前两个数组相加存到A[],后两个数组相加存到B[],然后再去枚举A中的每一个数到B中进行二分查找。
Code:
#include <iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int a[4005],b[4005],c[4005],d[4005],A[4000*4000+5],B[4000*4000+5];
int main()
{
int n;
while(~scanf("%d",&n))
{
for(int i=0;i<n;i++)
{
scanf("%d%d%d%d",&a[i],&b[i],&c[i],&d[i]);
}
int k=0;
for(int i=0;i<n;i++){
for(int j=0;j<n;j++){
A[k]=a[i]+b[j];
B[k]=c[i]+d[j];
k++;
}
}
sort(B,B+k);//B数组确保是有序的
int count=0;//记录满足条件的数目
for(int i=0;i<k;i++)
{
int begin=0,end=k-1;
while(begin<end)
{
int mid=begin+((end-begin)>>1);
if(B[mid]<-A[i])
begin=mid+1;
else
end=mid;
}
while(B[begin]==-A[i]&&begin<k)//防止B中有多个-A[i],避免后面重复计算
{
count++;
begin++;
}
}
printf("%d\n",count);
}
return 0;
}