POJ2785:4 Values whose Sum is 0(二分)

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

题意:每列找一个数,得到和为0的序列,有几种不同的方案
对1,2列的数求一个和,3,4列的数求一个和,然后进行二分查找

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <map>
using namespace std;
#define up(i,x,y) for(i=x;i<=y;i++)
#define down(i,x,y) for(i=x;i>=y;i--)
#define mem(a,b) memset(a,b,sizeof(a))
#define w(a) while(a)
#define ll long long
int n,a[4005],b[4005],c[4005],d[4005],sum1[16000005],sum2[16000005],len;

int main()
{
    int i,j,ans,l,r,mid;
    w(~scanf("%d",&n))
    {
        up(i,0,n-1)
        scanf("%d%d%d%d",&a[i],&b[i],&c[i],&d[i]);
        len=0;
        up(i,0,n-1)
        up(j,0,n-1)
        sum1[len++]=a[i]+b[j];
        len=0;
        up(i,0,n-1)
        up(j,0,n-1)
        sum2[len++]=c[i]+d[j];
        ans=0;
        sort(sum2,sum2+len);
        up(i,0,len-1)
        {
            l=0,r=len-1;
            w(l<r)
            {
                mid=(l+r)>>1;
                if(sum2[mid]<-sum1[i])
                    l=mid+1;
                else
                    r=mid;
            }
            while(sum2[l]==-sum1[i]&&l<len)
            {
                ans++;
                l++;
            }
        }
        printf("%d\n",ans);
    }

    return 0;
}


  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值