In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))
One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.
Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.
Output Specification:
For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.
Finally print in a line Max Heap
if it is a max heap, or Min Heap
for a min heap, or Not Heap
if it is not a heap at all.
Sample Input 1:
8
98 72 86 60 65 12 23 50
Sample Output 1:
98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap
Sample Input 2:
8
8 38 25 58 52 82 70 60
Sample Output 2:
8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap
Sample Input 3:
8
10 28 15 12 34 9 8 56
Sample Output 3:
10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap
题目大意:顺序输入完全二叉树的顶点,要求从右往左输出顶点到叶子结点的所有路径。然后判断该完全二叉树为大顶堆、小顶堆或者都不是。
分析:从右往左输出路径可以用DFS遍历。判断堆类型可以从第二个结点循环比较下一层结点大小,是递增还是递减或者都不是。
代码如下:
#include <bits/stdc++.h>
#include <iostream>
#include <vector>
using namespace std;
vector<int>v;
int a[1009],n,Min=1,Max=1;
void dfs(int d) //深度遍历输出结点
{
if (d*2>n&&d*2+1>n)
{
if (d<=n)
{
for (int i=0;i<v.size();i++)
printf("%d%s",v[i],i!=v.size()-1?" ":"\n");
}
}
else
{
v.push_back(a[d*2+1]);
dfs(d*2+1);
v.pop_back();
v.push_back(a[d*2]);
dfs(d*2);
v.pop_back();
}
}
int main() {
cin >> n;
for (int i=1;i<=n;i++)
scanf("%d",&a[i]);
v.push_back(a[1]);
dfs(1);
for (int i=2;i<=n;i++)//判断大小顶堆
{
if (a[i/2]>a[i]) Min=0;
if (a[i/2]<a[i]) Max=0;
}
if (Min==1)
printf("Min Heap");
else
printf("%s",Max==1?"Max Heap":"Not Heap");
return 0;
}