PAT-A 1155 Heap Paths

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

题意

这道题是给出层次遍历的完全二叉树序列,要求从右至左输出所有根节点到叶子节点的路径,并判断是否是大根堆或者小根堆

由于是完全二叉树,所以数组下标就可以确定节点在树中的位置,并且节点数目确定了路径的总数,路径总数=节点数/2+节点数%2。我的想法是从右到左找到所有叶子节点,然后叶子节点下标循环/2直到下标为1(根节点)。设置两个标志变量flagMax, flagMin,初始值都为1,如果不满足条件就将标记变量置0,最后判断一下输出结果就可以了。

从右至左找叶子节点,首先假设是一棵满二叉树,那么从1开始编号,最右边的叶子节点下标是2d-1(d表示树的深度),如果2d-1>n,说明没有该节点,判断2d- 2是否大于n,如果也大于n,说明最右边的叶子节点是上一层的最右边节点,即(2d - 1)/2。然后按照这个规则找到所有叶子节点。

求路径的时候是从叶子节点到根节点存储的,跟路径顺序是相反的,所以采用栈来存储,这样输出的时候就是正常的路径顺序。

Code

#include <stdio.h>
#include <vector>
#include <stack>
#include <math.h>
using namespace std;

int main(){
    int n, c = 1, l = 0;
    scanf("%d",&n);
    int key[n+1];
    for(int i = 1; i <= n; i++)
        scanf("%d", &key[i]);
    while(c < n + 1){ // 求完全二叉树的深度
        c *= 2;
        l++;
    }

    int num = n / 2 + n % 2; //路径总数
    vector<vector<int>> res;
    int flagMax = 1, flagMin = 1, max = pow(2, l) - 1; // max是深度为l的满二叉树节点的最大下标
    int leaf; // 叶子节点的下标
    // 找到最右边的叶子节点
    if(max > n && max - 1 > n) leaf = max / 2;
    else if(max == n) leaf = max;
    else if(max - 1 == n) leaf = max - 1;

    for(int i = 1; i <= num; i++){
        stack<int> route;
        int root = leaf;
        while(root != 0){
            route.push(key[root]);
            root /= 2;
        }

        vector<int> tmp;
        int size = route.size();
        int maxr = key[1], minr = key[1];
        while(!route.empty()){
            int t = route.top();
            if(t > maxr) flagMax = 0;
            if(t < minr) flagMin = 0;
            if(size != 1) printf("%d ", t);
            else printf("%d\n", t);
            tmp.push_back(t);
            maxr = t; minr = t;
            route.pop();
            size--;
        }

        res.push_back(tmp);
        // 找下一个叶子节点下标
        leaf--;
        if(leaf * 2 + 1 == n) leaf = leaf * 2 + 1;
        else if(leaf * 2 == n) leaf = leaf * 2;
    }

    if(flagMax == 0 && flagMin == 0) printf("Not Heap\n");
    else if(flagMax == 1) printf("Max Heap\n");
    else printf("Min Heap\n");
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值