HDU 2674 N!Again (数论)

N!Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4606    Accepted Submission(s): 2415


Problem Description
WhereIsHeroFrom:             Zty, what are you doing ?
Zty:                                     I want to calculate N!......
WhereIsHeroFrom:             So easy! How big N is ?
Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao?
Zty:                                     No. I haven's finished my saying. I just said I want to calculate N! mod 2009


Hint : 0! = 1, N! = N*(N-1)!
 

Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
 

Output
For each case, output N! mod 2009
 

Sample Input
  
  
4 5
 

Sample Output
  
  
24 120
 

  本人目前太菜,刚接触到真正的数论,为什么要说是真正的呢?因为以前曾经见过不少这种题目,一直以为是不涉及算法的题目,只是因为我不认识它而已。

  这个题目需要打表,把前2009个阶乘打表出来,因为2009后面是2008!*2009*……,所以后面的一定是0.

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    int n,a[2009]={1};
    for(int i=1;i<=2009;i++)//打表
    {
        a[i]=a[i-1]*i;
        a[i]%=2009;
    }
    while(~scanf("%d",&n))
    {
        if(n<2009)
            printf("%d\n",a[n]);
        else//后面都是0
        printf("0\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值