LightOJ 1232 Coin Change (II)(完全背包)

C - Coin Change (II)
Time Limit:1000MS    Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

In a strange shop there are n types of coins of value A1, A2 ... An. You have to find the number of ways you can makeK using the coins. You can use any coin at most K times.

For example, suppose there are three coins 1, 2, 5. Then if K = 5 the possible ways are:

11111

1112

122

5

So, 5 can be made in 4 ways.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing two integers n (1 ≤ n ≤ 100) andK (1 ≤ K ≤ 10000). The next line contains n integers, denotingA1, A2 ... An (1 ≤ Ai ≤ 500). AllAi will be distinct.

Output

For each case, print the case number and the number of ways K can be made. Result can be large, so, print the result modulo100000007.

Sample Input

2

3 5

1 2 5

4 20

1 2 3 4

Sample Output

Case 1: 4

Case 2: 108


题意:n种硬币,要得到k个硬币,每种硬币最多用k次,求方案数

思路:完全背包统计

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int dp[10005];
int main()
{
    int t,n,k,a[105],m=1;
    cin>>t;
    while(t--)
    {
        scanf("%d%d",&n,&k);
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
            //清零
            memset(dp,0,sizeof(dp));
            dp[0]=1;
            //控制格式
         if(m++)
            printf("Case %d: ",m-1);

            for(int i=1;i<=n;i++)//枚举物品的种类
            {
                for(int j=a[i];j<=k;j++)//枚举背包数量
                {
                     dp[j]=(dp[j]+dp[j-a[i]])%100000007;
                }
            }
            printf("%d\n",dp[k]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值