HDU 1299 Diophantus of Alexandria (数论)

Diophantus of Alexandria

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3078    Accepted Submission(s): 1200


Problem Description
Diophantus of Alexandria was an egypt mathematician living in Alexandria. He was one of the first mathematicians to study equations where variables were restricted to integral values. In honor of him, these equations are commonly called diophantine equations. One of the most famous diophantine equation is x^n + y^n = z^n. Fermat suggested that for n > 2, there are no solutions with positive integral values for x, y and z. A proof of this theorem (called Fermat's last theorem) was found only recently by Andrew Wiles.

Consider the following diophantine equation:  

1 / x + 1 / y = 1 / n where x, y, n ∈ N+ (1)


Diophantus is interested in the following question: for a given n, how many distinct solutions (i. e., solutions satisfying x ≤ y) does equation (1) have? For example, for n = 4, there are exactly three distinct solutions:  

1 / 5 + 1 / 20 = 1 / 4
1 / 6 + 1 / 12 = 1 / 4
1 / 8 + 1 / 8 = 1 / 4



Clearly, enumerating these solutions can become tedious for bigger values of n. Can you help Diophantus compute the number of distinct solutions for big values of n quickly?
 

Input
The first line contains the number of scenarios. Each scenario consists of one line containing a single number n (1 ≤ n ≤ 10^9).  
 

Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Next, print a single line with the number of distinct solutions of equation (1) for the given value of n. Terminate each scenario with a blank line.  
 

Sample Input
  
  
2 4 1260
 

Sample Output
  
  
Scenario #1: 3 Scenario #2: 113
 

  这是一道典型的数论题目,求N的因子个数,要求N的因子个数

另有一篇讲解见,传送门  因子的个数

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
const int N = 1000000;
int pr[N],primer[N];
int main()
{
    //素数打表
    memset(pr,1,sizeof(pr));
    for(int i=2;i<N;i++)
        for(int j=2;i*j<N;j++)
            pr[i*j]=0;
    int len = 0;
    for(int i=2;i<N;i++)
        if(pr[i])
            primer[len++]=i;
    int t,n;
    cin>>t;
    for(int m=1;m<=t;m++)
    {
        scanf("%d",&n);
        int sums=1;
        for(int i=0;primer[i]<=sqrt(n);i++)
        {
            int sum=0;
            while(n%primer[i]==0)
            {
                sum++;
                n/=primer[i];//找出n的因子的次方数
            }
            sums*=(2*sum+1);
        }
        if(n>1)
            sums*=3;//此时n也是因子,一次方,所以*=(2*1+1)
        printf("Scenario #%d:\n",m);
        printf("%d\n\n",(sums+1)/2);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值