2016 NCPC Game Rank(模拟)

G: Game Rank

时间限制: 1 Sec   内存限制: 64 MB
提交: 39   解决: 7
[ 提交][ 状态][ 讨论版]

题目描述


The gaming company Sandstorm is developing an online  two player game. You have been asked to implement  the ranking system. All players have a rank determining  their playing strength which gets updated after every game  played. There are 25 regular ranks, and an extra rank,  “Legend”, above that. The ranks are numbered in decreas ing order, 25 being the lowest rank, 1 the second highest  rank, and Legend the highest rank.
Each rank has a certain number of “stars” that one  needs to gain before advancing to the next rank. If a player  wins a game, she gains a star. If before the game the  player was on rank 6-25, and this was the third or more  consecutive win, she gains an additional bonus star for that  win. When she has all the stars for her rank (see list below)   and gains another star, she will instead gain one rank and have one star on the new rank. 
For instance, if before a winning game the player had all the stars on her current rank, she  will after the game have gained one rank and have 1 or 2 stars (depending on whether she got a  bonus star) on the new rank. If on the other hand she had all stars except one on a rank, and won  a game that also gave her a bonus star, she would gain one rank and have 1 star on the new rank. 
If a player on rank 1-20 loses a game, she loses a star. If a player has zero stars on a rank  and loses a star, she will lose a rank and have all stars minus one on the rank below. However,  one can never drop below rank 20 (losing a game at rank 20 with no stars will have no effect). 
If a player reaches the Legend rank, she will stay legend no matter how many losses she  incurs afterwards.
The number of stars on each rank are as follows:
• Rank 25-21: 2 stars
• Rank 20-16: 3 stars
• Rank 15-11: 4 stars
• Rank 10-1: 5 stars
A player starts at rank 25 with no stars. Given the match history of a player, what is her rank  at the end of the sequence of matches?

输入

The input consists of a single line describing the sequence of matches. Each character corre sponds to one game; ‘ W ’ represents a win and ‘ L ’ a loss. The length of the line is between 1 and  10 000 characters (inclusive).

输出

Output a single line containing a rank after having played the given sequence of games; either  an integer between 1 and 25 or “ Legend ”.

样例输入

WW

样例输出

25


题意:有Legend和1-25共26个等级,赢一局得到一个星星,如果连赢三局及以上并且等级在6-25之间可多得到一个星星,超过一定星星升级。输了并且在等级1-20,会失去一个星星,如果星星为负数并且在Legend和19之间会降级。

思路:


官方题解貌似:

import java.util.Scanner;
import java.util.stream.IntStream;

public class GameRank_Jimmy {
    public static void main(String[] args) {
        int starsPerRank[] = IntStream.range(0, 26).map(rank -> Math.min(5, 6 - (rank - 1) / 5)).toArray();
        String s = new Scanner(System.in).next();
        int rank = 25, stars = 0, cw = 0;
        for (int i = 0; i < s.length() && rank > 0; i++) {
            if (s.charAt(i) == 'W') {
                stars++;
                if (rank > 5 && ++cw >= 3) stars++;
                if (stars > starsPerRank[rank]) {
                    stars -= starsPerRank[rank];
                    rank--;
                }
            } else {
                cw = 0;
                if (rank <= 20) {
                    stars--;
                    if (stars < 0) {
                        if (rank == 20) {
                            stars = 0;
                        } else {
                            rank++;
                            stars = starsPerRank[rank] - 1;
                        }
                    }
                }
            }
        }
        System.out.println(rank == 0 ? "Legend" : rank);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值