1041 Be Unique (20 point(s)) - C语言 PAT 甲级

1041 Be Unique (20 point(s))

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤ 105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input:

7 5 31 5 88 67 88 17

Sample Output:

31

题目大意:

输入 N 个数字,按顺序读入,寻找第一个仅出现一次的数字,输出;若没有,则输出 None

设计思路:

两个数组,一个按顺序储存数字,另一个利用索引值储存对应数字的出现次数,再按顺序遍历一遍查找第一个仅出现一次的数字

编译器:C (gcc)
#include <stdio.h>

int main(void)
{
        int num[100001] = {0}, c[100001] = {0};
        int n;
        int i;

        scanf("%d", &n);
        for (i = 0; i < n; i++) {
                scanf("%d", &num[i]);
                c[num[i]]++;
        }
        for (i = 0; i < n; i++) {
                if (c[num[i]] == 1) {
                        printf("%d", num[i]);
                        return 0;
                }
        }
        if (i >= n) {
                printf("None");
        }

        return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值