1069 The Black Hole of Numbers (20point(s))
For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the black hole of 4-digit numbers. This number is named Kaprekar Constant.
For example, start from 6767, we’ll get:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …
Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.
Input Specification:
Each input file contains one test case which gives a positive integer N in the range (0,104).
Output Specification:
If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.
Sample Input:
6767
Sample Output:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
Sample Input:
2222
Sample Output:
2222 - 2222 = 0000
题目大意:
设计思路:
- 为四位数排序,然后输出
编译器:C (gcc)
#include <stdio.h>
#include <stdlib.h>
int sortnumber(int *n, int *m);
int compnumber(const void *a, const void *b);
int main()
{
int n = 0, m = 0;
scanf("%d", &n);
do{
sortnumber(&n, &m);
printf("%04d - %04d = %04d\n", n, m, n - m);
n = n - m;
}while(n != 0 && n != 6174);
return 0;
}
int sortnumber(int *n, int *m)
{
int number[4] = {*n/1000, *n%1000/100, *n%100/10, *n%10};
qsort(number, 4, sizeof(int), compnumber);
*n = number[0]*1000 + number[1]*100 + number[2]*10 + number[3];
*m = *n/1000 + *n%1000/100 *10 + *n%100/10 *100 + *n%10 *1000;
return 0;
}
int compnumber(const void *a, const void *b)
{
return *(int *)b - *(int *)a;
}