1075 PAT Judge (25point(s))
The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.
Input Specification:
Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤104), the total number of users, K (≤5), the total number of problems, and M (≤105), the total number of submissions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:
user_id problem_id partial_score_obtained
where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.
Output Specification:
For each test case, you are supposed to output the ranklist in the following format:
rank user_id total_score s[1] … s[K]
where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.
The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.
Sample Input:
7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0
Sample Output:
1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -
题目大意:
输入有 N 个考生,M 道题目,K 次提交,M 道题对应的满分,K 次提交记录包括考号,题号,得分
输出排名,按总分,得满分的个数,考号排序
设计思路:
排序题,按照题目排序输出即可
- 只要有一题编译通过,此考生即可参与排名,
- 可以参与排名,但有编译未通过的题目,视为 0 分记录
- 输入数据时,
-
代表编译未通过,而输出数据时-
代表未提交
编译器:C (gcc)
#include <stdio.h>
#include <stdlib.h>
struct node {
int rank, id, total, perfect, isshow;
int score[6], notcompiler[6];
};
struct node stu[10000];
int max(int a, int b)
{
return a > b ? a : b;
}
int cmp(const void *a, const void *b)
{
struct node *p = (struct node *)a, *q = (struct node *)b;
if (p->total != q->total)
return q->total - p->total;
else if (p->perfect != q->perfect)
return q->perfect - p->perfect;
else
return p->id - q->id;
}
int main(void)
{
int n, k, m, id, num, score, perfect[6];
int i, j;
scanf("%d%d%d", &n, &k, &m);
for (i = 1; i <= k; i++)
scanf("%d", &perfect[i]);
for (i = 0; i < m; i++) {
scanf("%d%d%d", &id, &num, &score);
stu[id].id = id;
stu[id].score[num] = max(stu[id].score[num], score);
if (score == -1 && stu[id].notcompiler[num] <= 0) {
stu[id].notcompiler[num] = -1;
} else {
stu[id].isshow = 1;
stu[id].notcompiler[num] = 1;
}
}
for (i = 1; i <= n; i++) {
for (j = 1; j <= k; j++) {
stu[i].total += stu[i].score[j];
if (stu[i].score[j] == perfect[j])
stu[i].perfect++;
}
}
qsort(stu + 1, n, sizeof(stu[0]), cmp);
stu[1].rank = 1;
for (i = 2; i <= n; i++)
if (stu[i].total == stu[i - 1].total)
stu[i].rank = stu[i - 1].rank;
else
stu[i].rank = i;
for (i = 1; i <= n; i++) {
if (stu[i].isshow == 1) {
printf("%d %05d %d", stu[i].rank, stu[i].id, stu[i].total);
for (j = 1; j <= k; j++)
if (stu[i].notcompiler[j] == 0)
printf(" -");
else
printf(" %d", stu[i].score[j]);
puts("");
}
}
return 0;
}