1080 Graduate Admission (30point(s)) - C语言 PAT 甲级

1080 Graduate Admission (30point(s))

It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade G​E​​, and the interview grade G​I​​. The final grade of an applicant is (G​E​​+G​I​​)/2. The admission rules are:

  • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.

  • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade G​E​​. If still tied, their ranks must be the same.

  • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one’s turn to be admitted; and if the quota of one’s most preferred shcool is not exceeded, then one will be admitted to this school, or one’s other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.

  • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:

Each input file contains one test case.

Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant’s G​E​​ and G​I​​, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M−1, and the applicants are numbered from 0 to N−1.

Output Specification:

For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants’ numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input:

11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4

Sample Output:
0 10
3
5 6 7
2 8

1 4
题目大意:

输入 N 个学生,M 所学校,K 个选报志愿

M 所学校录取的总人数

N 个 学生的信息,包括 GE、GI、K 个志愿学校

输出每个学校录取的学生 ID,打印 ID 按从小到大排序,没有学生输出空行

设计思路:

主要是注意录取规则:

  • 学生总分 total = GE + GI,不除以 2 也没关系,总分越高,学生排名越高,若 total 相等且 GE 相等,两学生排名相同
  • 按照学生排名由高到低,按照志愿尝试选择学校
    • 学校名额未满,学校录入学生
    • 学生排名和学校当前录取的最后一名学生排名相同,学校录入学生
  • 输出每所学校的学生 ID

注意:

  • 学生排序时,仅需考虑总分和 GE,学校志愿不需要参与排序
  • 学生排序后,数组下标和学生 ID 不能依次对应了,所以要在结构体中记录学生的 ID,在最后输出,当时居然没发现,找了半天 bug,哭 (ㄒoㄒ)
编译器:C (gcc)
#include <stdio.h>
#include <stdlib.h>

struct app {
        int id, ge, gi, total, rank;
        int choice[5];
};

struct sch {
        int quota, cnt;
        int stu[40000];
};

struct app apps[40000] = {0};
struct sch schs[100] = {0};

int cmp(const void *a, const void *b)
{
        struct app *p = (struct app *)a, *q = (struct app *)b;
        if (p->total != q->total)
                return q->total - p->total;
        //if (p->ge != q->ge)
                return q->ge - p->ge;
        return p->choice[0] - q->choice[0];
}

int cmp2(const void *a, const void *b)
{
        return apps[*((int *)a)].id - apps[*((int *)b)].id;
}

int main(void)
{
        int n, m, k;
        int i, j;

        scanf("%d%d%d", &n, &m, &k);
        for (i = 0; i < m; i++)
                scanf("%d", &schs[i].quota);
        for (i = 0; i < n; i++) {
                scanf("%d%d", &apps[i].ge, &apps[i].gi);
                apps[i].total = apps[i].ge + apps[i].gi;
                apps[i].id = i;
                for (j = 0; j < k; j++)
                        scanf("%d", &apps[i].choice[j]);
        }

        qsort(apps, n, sizeof(apps[0]), cmp);
        int schid, laststu;
        for (i = 0; i < n; i++) {
                for (j = 0; j < k; j++) {
                        schid = apps[i].choice[j];
                        laststu = schs[schid].stu[schs[schid].cnt - 1];
                        if (schs[schid].cnt < schs[schid].quota
                        || (apps[i].total == apps[laststu].total && apps[i].ge == apps[laststu].ge)) {
                                schs[schid].stu[schs[schid].cnt] = i;
                                schs[schid].cnt++;
                                break;
                        }
                }
        }
        for (i = 0; i < m; i++) {
                qsort(schs[i].stu, schs[i].cnt, sizeof(schs[i].stu[0]), cmp2);
                for (j = 0; j < schs[i].cnt; j++)
                        printf("%s%d", j == 0 ? "" : " ", apps[schs[i].stu[j]].id);
                puts("");
        }

        return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值