1117 Eddington Number (25point(s)) - C语言 PAT 甲级

1117 Eddington Number (25point(s))

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an “Eddington number”, E – that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington’s own E was 87.

Now given everyday’s distances that one rides for N days, you are supposed to find the corresponding E (≤N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:

10
6 7 6 9 3 10 8 2 7 8

Sample Output:

6

题目大意:

1060 爱丁顿数 (25point(s))

设计思路:

1060 爱丁顿数(C语言)

  • 初看题目有点绕,读懂题,重点在于求 E 天
  1. 降序排序骑车距离
  2. 天数由 0 升序,依次比较,即可找到最大天数
编译器:C (gcc)
#include <stdio.h>

int comp(const void *a, const void *b)
{
    return *(int*)b - *(int*)a;
}

int main()
{
    int n, e, miles[100000];
    int i;

    scanf("%d", &n);
    for(i = 0; i < n; i++)
        scanf("%d", miles + i);
    qsort(miles, n, sizeof(int), comp);
    for(e = 0; e < n && miles[e] > e + 1; e++)
        continue;

    printf("%d\n", e);

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值