1129 Recommendation System (25point(s))
Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user’s preference by the number of times that an item has been accessed by this user.
Input Specification:
Each input file contains one test case. For each test case, the first line contains two positive integers: N (≤ 50,000), the total number of queries, and K (≤ 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing – for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.
Output Specification:
For each case, process the queries one by one. Output the recommendations for each query in a line in the format:
query: rec[1] rec[2] … rec[K]
where query is the item that the user is accessing, and rec[i] (i=1, … K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.
Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.
Sample Input:
12 3
3 5 7 5 5 3 2 1 8 3 8 12
Sample Output:
5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8
题目大意:
输入 N 询问,最大值 K(K <= 10)
输出每次询问的编号,和相关推荐的编号,最多推荐 K 个值
推荐编号由用户询问数从多到少输出,若询问总次数相同,输出编号小的
设计思路:
- 利用数组记录每个编号询问的次数
- 推荐位未满最大值 K,直接进入推荐位,排序输出
- 推荐位已满最大值,仅需要和推荐位的末尾比较
注意:
- 每次询问过后,此编号的询问次数才能加 1
- 所以第一次询问时,推荐位为空,什么也不输出
- 题目中,K 最大为 10,所以排序最多只需要排 10 个数,最开始我直接全排序,然后直接超时
编译器:C (gcc)
#include <stdio.h>
struct node {
int num;
int cnt;
};
int cmp(const void *a, const void *b)
{
struct node *p = (struct node *)a, *q = (struct node *)b;
if (p->cnt != q->cnt)
return q->cnt - p->cnt;
return p->num - q->num;
}
int main(void)
{
int n, k;
int m[50010] = {0};
struct node s[10] = {0};
int num, f, i, j, count;//count 表示当前推荐位的总数
scanf("%d%d", &n, &k);
for (count = 0, i = 0; i < n; i++) {
scanf("%d", &num);
if (i != 0) {
printf("%d:", num);
qsort(s, count, sizeof(s[0]), cmp);
for (j = 0; j < k && j < count; j++)
printf(" %d", s[j].num);
printf("\n");
}
m[num]++;
for (f = 0; f < count && s[f].num != num; f++)
;
if (f < count) {
s[f].cnt = m[num];
} else {
if (f < k) {
s[count].num = num;
s[count].cnt = m[num];
count++;
} else if (s[k - 1].cnt < m[num] || (s[k - 1].cnt == m[num] && s[k - 1].num > num)) {
s[k - 1].num = num;
s[k - 1].cnt = m[num];
}
}
}
return 0;
}