1133 Splitting A Linked List (25 分)

11 篇文章 1 订阅
10 篇文章 0 订阅

Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.
Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤10​3​​). The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer in [−10​5​​,10​5​​], and Next is the position of the next node. It is guaranteed that the list is not empty.
Output Specification:

For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:

00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218

Sample Output:

33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

题意:给你给出三个数字,分别表示链表的头结点(起始位置),节点的个数和范围k。
现在让你排序输出节点。
思路:遍历一遍整个链表,将所有节点分为三类,分别是元素值小于0的,大于0但是小于k的,还有就是大于k的。做完了这些就直接输出就好了。第一次输出两个元素,后面输出三个元素,最后输出-1就结束了。

#include<bits/stdc++.h>
#pragma GCC optimize(2)
#define MAXN 100010
#define maxnode 2000005
#define sigma_size 26
#define md 12345678
#define INF 0x3f3f3f3f
using namespace std;
typedef long long LL;

int start,n,k;
struct node
{
    int val,nnxt;
    node(int val=0,int nnxt=0):val(val),nnxt(nnxt){};
};
node G[MAXN];
vector<int> P[3];

int main()
{
    scanf("%d %d %d",&start,&n,&k);
    for(int i=1;i<=n;i++)
    {
        int aa,vv,nnxt;
        scanf("%d %d %d",&aa,&vv,&nnxt);
        G[aa]={vv,nnxt};
        //printf("test:\n");
    }
    int head=start;
    while(head!=-1)
    {
        if(G[head].val<0)
            P[0].push_back(head);
        else if(0<=G[head].val&&G[head].val<=k)
            P[1].push_back(head);
        else
            P[2].push_back(head);
        head=G[head].nnxt;
    }
    bool first=true;
    for(int i=0;i<3;i++)
    {
        for(int j=0;j<P[i].size();j++)
        {
            if(first)
                printf("%05d %d ",P[i][j],G[P[i][j]].val),first=false;
            else
                printf("%05d\n%05d %d ",P[i][j],P[i][j],G[P[i][j]].val);
        }
    }
    printf("-1\n");
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值