1153 Decode Registration Card of PAT (25point(s)) - C语言 PAT 甲级

1153 Decode Registration Card of PAT (25point(s))

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee’s number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤10​4​​) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner’s score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.
Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt’s, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

题目大意:

1095 解码PAT准考证 (25point(s))

设计思路:

1095 解码PAT准考证(C语言)

  • 排好序按要求输出
编译器:C (gcc)
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct id{
        char str[14];
        char level[2];
        int room;
        int date;
        int num;
        int score;
};

int cmp(const void *a, const void *b)
{
        struct id *ida = (struct id*)a, *idb = (struct id*)b;
        if (ida->score != idb->score)
                return idb->score - ida->score;
        return strcmp(ida->str, idb->str);
}

int type1(struct id ids[], int n, int i);
int type2(struct id ids[], int n, int i);
int type3(struct id ids[], int n, int i);

int main()
{
        struct id ids[10000];
        int n, m, type;
        int i;
        char level[2];

        scanf("%d %d", &n, &m);
        for (i = 0; i < n; i++) {
                scanf("%s %d", ids[i].str, &ids[i].score);
                sscanf(ids[i].str, "%1s%3d%6d%3d", ids[i].level,
                                &ids[i].room, &ids[i].date, &ids[i].num);
        }

        qsort(ids, n, sizeof(ids[0]), cmp);

        for (i = 0; i < m; i++) {
                scanf("%d", &type);
                if (type == 1)
                        type1(ids, n, i);
                else if (type == 2)
                        type2(ids, n, i);
                else if (type == 3)
                        type3(ids, n, i);
        }

        return 0;
}

int type1(struct id ids[], int n, int i)
{
        char level[2];
        int f = 1, j;
        scanf("%1s", level);
        printf("Case %d: %d %c\n", i + 1, 1, level[0]);
        for (j = 0; j < n; j++)
                if (ids[j].level[0] == level[0]) {
                        f = 0;
                        printf("%s %d\n", ids[j].str,ids[j].score);
                }
        if (f)
                puts("NA");
        return 0;
}

int type2(struct id ids[], int n, int i)
{
        int room, sum = 0, count = 0;
        int j, f = 1;

        scanf("%d", &room);
        printf("Case %d: %d %d\n", i + 1, 2, room);
        for (j = 0; j < n; j++)
                if (ids[j].room == room) {
                        f = 0;
                        count++;
                        sum += ids[j].score;
                }
        if (f)
                puts("NA");
        else
                printf("%d %d\n", count, sum);

        return 0;
}

int type3(struct id ids[], int n, int i)
{
        int date, max = 0, rooms[1000] = {0};
        int f = 1, j;

        scanf("%d", &date);
        printf("Case %d: %d %06d\n", i + 1, 3, date);
        for (j = 0; j < n; j++)
                if (ids[j].date == date) {
                        f = 0;
                        rooms[ids[j].room]++;
                        if (max < rooms[ids[j].room])
                                max = rooms[ids[j].room];
                }
        if (f)
                puts("NA");
        else
                for (; max > 0; max--)
                        for (j = 101; j < 1000; j++)
                                if (rooms[j] == max)
                                        printf("%d %d\n", j, max);

        return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值