【PAT甲级A1153】Decode Registration Card of PAT (25分)(c++)

1153 Decode Registration Card of PAT (25分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

A registration card number of PAT consists of 4 parts:

the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
the 2nd - 4th digits are the test site number, ranged from 101 to 999;
the 5th - 10th digits give the test date, in the form of yymmdd;
finally the 11th - 13th digits are the testee’s number, ranged from 000 to 999.
Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤10​4​​ ) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner’s score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;

  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;

  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.
    Output Specification:
    For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);

  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;

  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt’s, or in increasing order of site numbers if there is a tie of Nt.
    If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

题意:

给出n歌学生的id和分数,id由考试等级+考场号+考生号+日期组成,根据要求输出,

  • 情况1,给出考试类型,将所有该类型学生按成绩降序输出
  • 情况2,给出考场号,统计共有多少学生在这个考场,并统计总分
  • 情况3,给出日期,统计该日期有多少考场考试,按照考场人数降序输出

思路:

创建结构体,将学生信息保存在容器中,根据不同的要求遍历容器,情况3,用map映射考场号和人数。排序是情况1和情况3都是按照数字降序,字符串升序。若没有输出,则输出NA。

参考代码:

#include <iostream>
#include <vector>
#include <unordered_map>
#include <algorithm>

using namespace std;
struct node {
    string id;
    int score;
};

bool cmp(node a, node b) {
    return a.score != b.score ? a.score > b.score : a.id < b.id;
}

int main() {
    int n, m, a;
    string s;
    scanf("%d%d", &n, &m);
    vector<node> v(n);
    for (int i = 0; i < n; ++i) cin >> v[i].id >> v[i].score;
    for (int i = 0; i < m; ++i) {
        vector<node> temp;
        int cnt = 0, ans = 0;
        cin >> a >> s;
        printf("Case %d: %d %s\n", i + 1, a, s.c_str());
        if (a == 1) {
            for (int j = 0; j < n; ++j)
                if (v[j].id[0] == s[0])temp.push_back(v[j]);
        } else if (a == 2) {
            for (int j = 0; j < n; ++j) {
                if (v[j].id.substr(1, 3) == s) {
                    cnt++;
                    ans += v[j].score;
                }
            }
            if (cnt != 0)printf("%d %d\n", cnt, ans);
        } else {
            unordered_map<string, int> mp;
            for (int j = 0; j < n; ++j) {
                if (v[j].id.substr(4, 6) == s)mp[v[j].id.substr(1, 3)]++;
            }
            for (auto it:mp)temp.push_back({it.first, it.second});
        }
        sort(temp.begin(), temp.end(), cmp);
        for (int j = 0; j < temp.size(); ++j) printf("%s %d\n", temp[j].id.c_str(), temp[j].score);
        if (((a == 1 || a == 3) && temp.size() == 0) || (a == 2 && cnt == 0))printf("NA\n");
    }
    return 0;
}

如有错误,欢迎指正

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值