1022 Digital Library (30 point(s)) - C语言 PAT 甲级

1022 Digital Library (30 point(s))

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID’s.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤ 104) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title – a string of no more than 80 characters;
  • Line #3: the author – a string of no more than 80 characters;
  • Line #4: the key words – each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher – a string of no more than 80 characters;
  • Line #6: the published year – a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤ 1000) which is the number of user’s search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year
Output Specification:

For each query, first print the original query in a line, then output the resulting book ID’s in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

题目大意:

输入 N 本书的信息,M 个需要查询的命令,输出满足查询条件的书的 ID,按从小到大顺序

设计思路:
  • 结构体存储书的信息
  • 每次查询命令对应一次查询
    • 查询函数中,因为结构体内成员的地址是相对地址,所以利用偏移量对应每次查询

注:若是把结构体中 keywords[] 改成一维数组,直接存储一行,keysearch 函数可以直接利用 strstr() 进行子串匹配,不仅能 AC,速度还很快(有匹配到更小子串的风险,但似乎并没有这样的测试点~)

编译器:C (gcc)
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct book {
        char id[8];
        char title[81];
        char author[81];
        char keywords[5][11];
        char publisher[81];
        char pubyear[5];
};

int cmp(const void *a, const void *b)
{
        return strcmp(((struct book*)a)->id, ((struct book*)b)->id);
}

void search(struct book books[], char s[], int n, int m)
{
        int f = 0, i = 0;
        for (; i < n; i++) {
                if (strcmp(books[i].id + m, s) == 0) {
                        f = 1;
                        printf("%s\n", books[i].id);
                }
        }
        if (f == 0)
                printf("Not Found\n");
}

void keysearch(struct book books[], char s[], int n)
{
        int f = 0, i, j;
        for (i = 0; i < n; i++) {
                for (j = 0; j < 5; j++) {
                        if (strcmp(books[i].keywords[j], s) == 0) {
                                f = 1;
                                printf("%s\n", books[i].id);
                                break;
                        }
                }
        }
        if (f == 0)
                printf("Not Found\n");
}

int main(void)
{
        int n, m;
        struct book books[10001] = {0};
        int i;
        scanf("%d", &n);getchar();
        for (i = 0; i < n; i++) {
                gets(books[i].id);
                gets(books[i].title);
                gets(books[i].author);
                int j = 0;
                char c = 0;
                while (scanf("%s%c", books[i].keywords[j], &c) && c != '\n')
                        j++;
                gets(books[i].publisher);
                gets(books[i].pubyear);
        }
        qsort(books, n, sizeof(struct book), cmp);

        int move[6] = {0};
        struct book *p = NULL;
        for (i = 1; i < 6; i++)
                switch (i) {
                        case 1: move[i] = (char*)(p->title) - (char*)p; break;
                        case 2: move[i] = (char*)(p->author) - (char*)p; break;
                        case 4: move[i] = (char*)(p->publisher) - (char*)p; break;
                        case 5: move[i] = (char*)(p->pubyear) - (char*)p; break;
                        default: break;
                }

        scanf("%d", &m);
        while (m--) {
                int num;
                char s[100] =  {0};
                scanf("%d: ", &num);
                gets(s);
                printf("%d: %s\n", num, s);
                if (num == 3)
                        keysearch(books, s, n);
                else
                        search(books, s, n, move[num]);
        }
        return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值