A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:
- Line #1: the 7-digit ID number;
- Line #2: the book title -- a string of no more than 80 characters;
- Line #3: the author -- a string of no more than 80 characters;
- Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
- Line #5: the publisher -- a string of no more than 80 characters;
- Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].
It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.
After the book information, there is a line containing a positive integer M (<=1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:
- 1: a book title
- 2: name of an author
- 3: a key word
- 4: name of a publisher
- 5: a 4-digit number representing the year
Output Specification:
For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print "Not Found" instead.
Sample Input:3 1111111 The Testing Book Yue Chen test code debug sort keywords ZUCS Print 2011 3333333 Another Testing Book Yue Chen test code sort keywords ZUCS Print2 2012 2222222 The Testing Book CYLL keywords debug book ZUCS Print2 2011 6 1: The Testing Book 2: Yue Chen 3: keywords 4: ZUCS Print 5: 2011 3: blablablaSample Output:
1: The Testing Book 1111111 2222222 2: Yue Chen 1111111 3333333 3: keywords 1111111 2222222 3333333 4: ZUCS Print 1111111 5: 2011 1111111 2222222 3: blablabla Not Found
solution:
#include<iostream>
#include<fstream>
#include<hash_map>
#include<string>
#include<sstream>
#include<algorithm>
using namespace std;
using namespace __gnu_cxx;
struct str_hash//哈希函数对象
{
size_t operator()(const string& str) const
{
unsigned long __h = 0;
for(size_t i = 0;i < str.size();++ i)
__h = 5 * __h + str[i];
return size_t(__h);
}
};
int main()
{
vector<string> num;//存储每个序号
hash_multimap<string,int,str_hash> title,author,keywords,publisher,year; //存储搜索项到序号的hash
string x,t,a,k,p,y;
int n;
string dustbin;
cin >> n;
getline(cin,dustbin);
for(int i = 0;i < n;++ i)
{
getline(cin,x);
getline(cin,t);
getline(cin,a);
getline(cin,k);
getline(cin,p);
getline(cin,y);
num.push_back(x);
title.insert(make_pair(t,i));
author.insert(make_pair(a,i));
publisher.insert(make_pair(p,i));
year.insert(make_pair(y,i));
size_t pos1 = 0;
size_t pos2 = 0;
while(pos2 != string::npos)
{
pos2 = k.find(' ',pos1);
string tmp = k.substr(pos1,pos2 - pos1);
pos1 = pos2 + 1;
keywords.insert(make_pair(tmp,i));
}
}
cin >> n;
getline(cin,dustbin);
vector<string> query;
for(int i = 0;i < n;++ i)
{
string tmp;
getline(cin,tmp);
query.push_back(tmp);
}
vector<string> result;
ostringstream os;
for(size_t i = 0;i < query.size();++ i)
{
result.clear();
os << query[i] << endl;
int count;
char c = (query[i])[0];
string s = (query[i]).substr(3);
hash_multimap<string,int,str_hash>::iterator it;
switch(c)
{
case '1':
count = title.count(s);
it = title.find(s);
if(count > 0)
for(int j = 0;j < count;++ j)
{
result.push_back(num[it->second]);
++ it;
}
if(result.size() > 0)
{
sort(result.begin(),result.end());
for(size_t j = 0;j < result.size();++ j)
{
os << result[j];
if(!((j == result.size() - 1) && (i == query.size() - 1)))
os << endl;
}
}
else
{
os << "Not Found";
if(i != query.size() - 1)
os << endl;
}
break;
case '2':
count = author.count(s);
it = author.find(s);
if(count > 0)
for(int j = 0;j < count;++ j)
{
result.push_back(num[it->second]);
++ it;
}
if(result.size() > 0)
{
sort(result.begin(),result.end());
for(size_t j = 0;j < result.size();++ j)
{
os << result[j];
if(!((j == result.size() - 1) && (i == query.size() - 1)))
os << endl;
}
}
else
{
os << "Not Found";
if(i != query.size() - 1)
os << endl;
}
break;
case '3':
count = keywords.count(s);
it = keywords.find(s);
if(count > 0)
for(int j = 0;j < count;++ j)
{
result.push_back(num[it->second]);
++ it;
}
if(result.size() > 0)
{
sort(result.begin(),result.end());
for(size_t j = 0;j < result.size();++ j)
{
os << result[j];
if(!((j == result.size() - 1) && (i == query.size() - 1)))
os << endl;
}
}
else
{
os << "Not Found";
if(i != query.size() - 1)
os << endl;
}
break;
case '4':
count = publisher.count(s);
it = publisher.find(s);
if(count > 0)
for(int j = 0;j < count;++ j)
{
result.push_back(num[it->second]);
++ it;
}
if(result.size() > 0)
{
sort(result.begin(),result.end());
for(size_t j = 0;j < result.size();++ j)
{
os << result[j];
if(!((j == result.size() - 1) && (i == query.size() - 1)))
os << endl;
}
}
else
{
os << "Not Found";
if(i != query.size() - 1)
os << endl;
}
break;
case '5':
count = year.count(s);
it = year.find(s);
if(count > 0)
for(int j = 0;j < count;++ j)
{
result.push_back(num[it->second]);
++ it;
}
if(result.size() > 0)
{
sort(result.begin(),result.end());
for(size_t j = 0;j < result.size();++ j)
{
os << result[j];
if(!((j == result.size() - 1) && (i == query.size() - 1)))
os << endl;
}
}
else
{
os << "Not Found";
if(i != query.size() - 1)
os << endl;
}
break;
default:
cout << "Not Found";
if(i != query.size() - 1)
cout << endl;
break;
}
}
cout << os.str();
}