湖南师范大学OJ-10021

Lowest Bit
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:32768KB
Total submit users: 22, Accepted users: 22
Problem 10021 : No special judgement
Problem description
Given an positive integer A (1 <= A <= 10^9), output the lowest bit of A.
For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.
Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.



Input
Each line of input contains only an integer A (1 <= A <= 109). A line containing "0" indicates the end of input, and this line is not a part of the input data.


Output
For each A in the input, output a line containing only its lowest bit.


Sample Input
26
8
0

Sample Output
2
8




import java.util.Scanner;


public class Acm10021 {

public static void main(String[] args) {
Scanner cin = new Scanner(System.in);
Integer a = cin.nextInt();
String binaryNum = null;
String suffixNum = null;
int result;
while(a != 0){
result = 0;
binaryNum = new String();
binaryNum = Integer.toBinaryString(a);
suffixNum = new String();
suffixNum = binaryNum.substring(binaryNum.lastIndexOf("1"), binaryNum.length());
int j=0;
for(int i=suffixNum.length(); i>0; i--){
result += Integer.parseInt(suffixNum.substring(i-1, i))*Math.pow(2, j);
j++;
}
System.out.println(result);
a = cin.nextInt();
}
}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值