华为oj:输入一行字符,分别统计出包含英文字母、空格、数字和其它字符的个数

/*输入
输入一行字符串,可以有空格
输出
统计其中英文字符,空格字符,数字字符,其他字符的个数
样例输入 1qazxsw23 edcvfr45tgbn hy67uj m,ki89ol.\/;p0-=\][
样例输出 26 3 10 12*/
华为oj测试的时候,一般输出都会采用换行格式,不然编译说格式错误,请大家注意

#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
#include<cctype>
using namespace std;

int main(){
    string str;
    getline(cin, str);
    int letter_num = 0, space_num = 0, digit_num = 0, oher_num = 0;
    for (int i = 0; i != str.size(); i++){
        if (isalpha(str[i])) letter_num++;  
        else if (isspace(str[i])) space_num++;
        else if (isdigit(str[i])) digit_num++;
        else oher_num++;
    }
    cout << letter_num << endl << space_num << endl << digit_num << endl << oher_num << endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值